<!DOCTYPE html>
<!--[if IE 7]><html class="ie ie7" lang="en-US"
	prefix="og: https://ogp.me/ns#"  xmlns:og="http://opengraphprotocol.org/schema/" xmlns:fb="http://www.facebook.com/2008/fbml"><![endif]-->
<!--[if IE 8]><html class="ie ie8" lang="en-US"
	prefix="og: https://ogp.me/ns#"  xmlns:og="http://opengraphprotocol.org/schema/" xmlns:fb="http://www.facebook.com/2008/fbml"><![endif]-->
<!--[if !(IE 7) | !(IE 8)  ]><!--><html lang="en-US"
	prefix="og: https://ogp.me/ns#"  xmlns:og="http://opengraphprotocol.org/schema/" xmlns:fb="http://www.facebook.com/2008/fbml"><!--<![endif]-->

<head>
	
<!-- Begin Sortable header code for ad tags -->
<script src="//tags-cdn.deployads.com/a/mmaweekly.com.js" async ></script>
<!-- End Sortable header code for ad tags -->
  
<!-- Begin Taboola header code -->
<script type="text/javascript">
  window._taboola = window._taboola || [];
  _taboola.push({article:'auto'});
  !function (e, f, u, i) {
    if (!document.getElementById(i)){
      e.async = 1;
      e.src = u;
      e.id = i;
      f.parentNode.insertBefore(e, f);
    }
  }(document.createElement('script'),
  document.getElementsByTagName('script')[0],
  '//cdn.taboola.com/libtrc/mmaweeklycom-network/loader.js',
  'tb_loader_script');
  if(window.performance && typeof window.performance.mark == 'function')
    {window.performance.mark('tbl_ic');}
</script>
<!-- End Taboola header code -->
	
<link rel="preload" href="https://cdn.mmaweekly.com/wp-content/themes/orion/css/font-awesome/font/fontawesome-webfont.woff?v=3.2.1" as="font" type="font/woff2">
	
	
    <meta charset="UTF-8" />
    <meta http-equiv="Content-Type" content="text/html; charset=UTF-8">
	<link rel="pingback" href="https://www.mmaweekly.com/xmlrpc.php" />
			<meta name="viewport" content="width=device-width, initial-scale=1.0">
			
			<link rel="shortcut icon" href="https://cdn.mmaweekly.com/wp-content/uploads/2014/10/MMAWeekly-Favicon-16x16-Rounded.png" type="image/x-icon" />
		
			<!-- For iPhone -->
		<link rel="apple-touch-icon-precomposed" href="https://cdn.mmaweekly.com/wp-content/uploads/2014/10/MMAWeekly-Favicon-57x57-Rounded.png">
	
			<!-- For iPhone 4 Retina display -->
		<link rel="apple-touch-icon-precomposed" sizes="114x114" href="https://cdn.mmaweekly.com/wp-content/uploads/2014/10/MMAWeekly-Favicon-114x114-Rounded.png">
	
			<!-- For iPad -->
		<link rel="apple-touch-icon-precomposed" sizes="72x72" href="https://cdn.mmaweekly.com/wp-content/uploads/2014/10/MMAWeekly-Favicon-72x72-Rounded.png">
	
			<!-- For iPad Retina display -->
		<link rel="apple-touch-icon-precomposed" sizes="144x144" href="https://cdn.mmaweekly.com/wp-content/uploads/2014/10/MMAWeekly-Favicon-144x144-Rounded.png">
		
		
	
		<!-- All in One SEO 4.0.17 -->
		<title>Kevin Holland steps in to face Marvin Vettori in UFC on ABC 2 main event</title>
		<meta name="description" content="No. 10 ranked middleweight Kevin Holland will be competing in his second main event in three weeks, taking on no. 6 ranked Marvin Vettori at UFC on ABC 2."/>
		<meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1"/>
		<meta name="keywords" content="darren till,kevin holland,marvin vettori,ufc,ufc las vegas 23,ufc news,ufc on abc 2,front page,news,trending" />
		<link rel="canonical" href="https://www.mmaweekly.com/kevin-holland-steps-in-to-face-marvin-vettori-in-ufc-on-abc-2-main-event" />
		<meta property="og:site_name" content="MMAWeekly.com | UFC News and MMA News, UFC Rumors, Rankings, Fight Cards, Photos, Results, and Videos" />
		<meta property="og:type" content="article" />
		<meta property="og:title" content="Kevin Holland steps in to face Marvin Vettori in UFC on ABC 2 main event" />
		<meta property="og:description" content="No. 10 ranked middleweight Kevin Holland will be competing in his second main event in three weeks, taking on no. 6 ranked Marvin Vettori at UFC on ABC 2." />
		<meta property="og:url" content="https://www.mmaweekly.com/kevin-holland-steps-in-to-face-marvin-vettori-in-ufc-on-abc-2-main-event" />
		<meta property="og:image" content="https://cdn.mmaweekly.com/wp-content/uploads/2020/11/Kevin-Holland.jpg" />
		<meta property="og:image:secure_url" content="https://cdn.mmaweekly.com/wp-content/uploads/2020/11/Kevin-Holland.jpg" />
		<meta property="og:image:width" content="750" />
		<meta property="og:image:height" content="370" />
		<meta property="article:tag" content="darren till" />
		<meta property="article:tag" content="kevin holland" />
		<meta property="article:tag" content="marvin vettori" />
		<meta property="article:tag" content="ufc" />
		<meta property="article:tag" content="ufc las vegas 23" />
		<meta property="article:tag" content="ufc news" />
		<meta property="article:tag" content="ufc on abc 2" />
		<meta property="article:tag" content="front page" />
		<meta property="article:tag" content="news" />
		<meta property="article:tag" content="trending" />
		<meta property="article:published_time" content="2021-04-01T23:20:15Z" />
		<meta property="article:modified_time" content="2021-04-01T23:20:18Z" />
		<meta property="article:publisher" content="https://www.facebook.com/MMAWeeklyOfficial/" />
		<meta property="twitter:card" content="summary_large_image" />
		<meta property="twitter:site" content="@mmaweeklycom" />
		<meta property="twitter:domain" content="www.mmaweekly.com" />
		<meta property="twitter:title" content="Kevin Holland steps in to face Marvin Vettori in UFC on ABC 2 main event" />
		<meta property="twitter:description" content="No. 10 ranked middleweight Kevin Holland will be competing in his second main event in three weeks, taking on no. 6 ranked Marvin Vettori at UFC on ABC 2." />
		<meta property="twitter:image" content="https://cdn.mmaweekly.com/wp-content/uploads/2020/11/Kevin-Holland.jpg" />
		<script type="application/ld+json" class="aioseo-schema">
			{"@context":"https:\/\/schema.org","@graph":[{"@type":"WebSite","@id":"https:\/\/www.mmaweekly.com\/#website","url":"https:\/\/www.mmaweekly.com\/","name":"MMAWeekly.com","description":"UFC News and MMA News, UFC Rumors, Rankings, Fight Cards, Photos, Results, and Videos","publisher":{"@id":"https:\/\/www.mmaweekly.com\/#organization"}},{"@type":"Organization","@id":"https:\/\/www.mmaweekly.com\/#organization","name":"MMAWeekly LLC","url":"https:\/\/www.mmaweekly.com\/","sameAs":["https:\/\/www.facebook.com\/MMAWeeklyOfficial\/","https:\/\/twitter.com\/mmaweeklycom","https:\/\/www.instagram.com\/mmaweekly\/","https:\/\/www.youtube.com\/c\/mmaweekly"]},{"@type":"BreadcrumbList","@id":"https:\/\/www.mmaweekly.com\/kevin-holland-steps-in-to-face-marvin-vettori-in-ufc-on-abc-2-main-event#breadcrumblist","itemListElement":[{"@type":"ListItem","@id":"https:\/\/www.mmaweekly.com\/#listItem","position":"1","item":{"@id":"https:\/\/www.mmaweekly.com\/#item","name":"Home","description":"MMAWeekly.com is a UFC and MMA news and fan site, reporting on mixed martial arts. It was founded in 2002 by Ryan Bennett and Scott Petersen.","url":"https:\/\/www.mmaweekly.com\/"}}]},{"@type":"Person","@id":"https:\/\/www.mmaweekly.com\/author\/hunter-brownstein#author","url":"https:\/\/www.mmaweekly.com\/author\/hunter-brownstein","name":"Hunter Brownstein","image":{"@type":"ImageObject","@id":"https:\/\/www.mmaweekly.com\/kevin-holland-steps-in-to-face-marvin-vettori-in-ufc-on-abc-2-main-event#authorImage","url":"https:\/\/secure.gravatar.com\/avatar\/2f827276bbfdaf910ef911714bd36e8e?s=96&d=mm&r=pg","width":"96","height":"96","caption":"Hunter Brownstein"},"sameAs":["https:\/\/twitter.com\/mmaweeklycom","https:\/\/www.instagram.com\/mmaweekly\/","https:\/\/www.youtube.com\/c\/mmaweekly"]},{"@type":"WebPage","@id":"https:\/\/www.mmaweekly.com\/kevin-holland-steps-in-to-face-marvin-vettori-in-ufc-on-abc-2-main-event#webpage","url":"https:\/\/www.mmaweekly.com\/kevin-holland-steps-in-to-face-marvin-vettori-in-ufc-on-abc-2-main-event","name":"Kevin Holland steps in to face Marvin Vettori in UFC on ABC 2 main event","description":"No. 10 ranked middleweight Kevin Holland will be competing in his second main event in three weeks, taking on no. 6 ranked Marvin Vettori at UFC on ABC 2.","inLanguage":"en-US","isPartOf":{"@id":"https:\/\/www.mmaweekly.com\/#website"},"breadcrumb":{"@id":"https:\/\/www.mmaweekly.com\/kevin-holland-steps-in-to-face-marvin-vettori-in-ufc-on-abc-2-main-event#breadcrumblist"},"author":"https:\/\/www.mmaweekly.com\/kevin-holland-steps-in-to-face-marvin-vettori-in-ufc-on-abc-2-main-event#author","creator":"https:\/\/www.mmaweekly.com\/kevin-holland-steps-in-to-face-marvin-vettori-in-ufc-on-abc-2-main-event#author","image":{"@type":"ImageObject","@id":"https:\/\/www.mmaweekly.com\/#mainImage","url":"https:\/\/cdn.mmaweekly.com\/wp-content\/uploads\/2020\/11\/Kevin-Holland.jpg","width":"750","height":"370","caption":"Kevin Holland"},"primaryImageOfPage":{"@id":"https:\/\/www.mmaweekly.com\/kevin-holland-steps-in-to-face-marvin-vettori-in-ufc-on-abc-2-main-event#mainImage"},"datePublished":"2021-04-01T23:20:15-04:00","dateModified":"2021-04-01T23:20:18-04:00"},{"@type":"Article","@id":"https:\/\/www.mmaweekly.com\/kevin-holland-steps-in-to-face-marvin-vettori-in-ufc-on-abc-2-main-event#article","name":"Kevin Holland steps in to face Marvin Vettori in UFC on ABC 2 main event","description":"No. 10 ranked middleweight Kevin Holland will be competing in his second main event in three weeks, taking on no. 6 ranked Marvin Vettori at UFC on ABC 2.","headline":"Kevin Holland steps in to face Marvin Vettori in UFC on ABC 2 main event","author":{"@id":"https:\/\/www.mmaweekly.com\/author\/hunter-brownstein#author"},"publisher":{"@id":"https:\/\/www.mmaweekly.com\/#organization"},"datePublished":"2021-04-01T23:20:15-04:00","dateModified":"2021-04-01T23:20:18-04:00","articleSection":"Front Page, News, Trending, UFC News, Darren Till, Kevin Holland, Marvin Vettori, UFC, UFC Las Vegas 23, UFC news, UFC on ABC 2","mainEntityOfPage":{"@id":"https:\/\/www.mmaweekly.com\/kevin-holland-steps-in-to-face-marvin-vettori-in-ufc-on-abc-2-main-event#webpage"},"isPartOf":{"@id":"https:\/\/www.mmaweekly.com\/kevin-holland-steps-in-to-face-marvin-vettori-in-ufc-on-abc-2-main-event#webpage"},"image":{"@type":"ImageObject","@id":"https:\/\/www.mmaweekly.com\/#articleImage","url":"https:\/\/cdn.mmaweekly.com\/wp-content\/uploads\/2020\/11\/Kevin-Holland.jpg","width":"750","height":"370","caption":"Kevin Holland"}}]}
		</script>
		<script type="text/javascript" >
			window.ga=window.ga||function(){(ga.q=ga.q||[]).push(arguments)};ga.l=+new Date;
			ga('create', "UA-677267-1", { 'cookieDomain': 'www.mmaweekly.com' } );
			ga('send', 'pageview');
		</script>
		<script async src="https://www.google-analytics.com/analytics.js"></script>
		<!-- All in One SEO -->

<link rel='dns-prefetch' href='//platform.twitter.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="MMAWeekly.com &raquo; Feed" href="https://www.mmaweekly.com/feed" />
<link rel="alternate" type="application/rss+xml" title="MMAWeekly.com &raquo; Comments Feed" href="https://www.mmaweekly.com/comments/feed" />
<link rel="alternate" type="application/rss+xml" title="MMAWeekly.com &raquo; Kevin Holland steps in to face Marvin Vettori in UFC on ABC 2 main event Comments Feed" href="https://www.mmaweekly.com/kevin-holland-steps-in-to-face-marvin-vettori-in-ufc-on-abc-2-main-event/feed" />
<meta property="fb:admins" content="1293214633"/><meta property="og:title" content="Kevin Holland steps in to face Marvin Vettori in UFC on ABC 2 main event"/><meta property="og:type" content="article"/><meta property="og:url" content="https://www.mmaweekly.com/kevin-holland-steps-in-to-face-marvin-vettori-in-ufc-on-abc-2-main-event"/><meta property="og:site_name" content="MMAWeekly.com”/><meta property="og:image" content="https://cdn.mmaweekly.com/wp-content/uploads/2020/11/Kevin-Holland-375x185.jpg"/>
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/cdn.mmaweekly.com\/wp-includes\/js\/wp-emoji-release.min.js"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://cdn.mmaweekly.com/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='owl_stylesheet-css'  href='https://cdn.mmaweekly.com/wp-content/themes/orion/js/owl_carousel/assets/owl.carousel.css' type='text/css' media='all' />
<link rel='stylesheet' id='google_fonts-css'  href='https://fonts.googleapis.com/css?family=Lato%7COswald%7COswald%3A400%2C400italic%2C700%2C700italic&#038;subset=latin%2Cgreek-ext%2Ccyrillic%2Clatin-ext%2Cgreek%2Ccyrillic-ext%2Cvietnamese&#038;ver=5.7' type='text/css' media='all' />
<link rel='stylesheet' id='bootstrap-css'  href='https://cdn.mmaweekly.com/wp-content/themes/orion/css/bootstrap.css' type='text/css' media='all' />
<link rel='stylesheet' id='style-css'  href='https://cdn.mmaweekly.com/wp-content/themes/orion/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='awesome-css'  href='https://cdn.mmaweekly.com/wp-content/themes/orion/css/font-awesome/css/font-awesome.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='magnific-popup-css'  href='https://cdn.mmaweekly.com/wp-content/themes/orion/css/magnific-popup.css' type='text/css' media='all' />
<link rel='stylesheet' id='visual-composer-css'  href='https://cdn.mmaweekly.com/wp-content/themes/orion/css/visual-composer.css' type='text/css' media='all' />
<link rel='stylesheet' id='responsive-css'  href='https://cdn.mmaweekly.com/wp-content/themes/orion/css/responsive.css' type='text/css' media='all' />
<link rel='stylesheet' id='nextgen_widgets_style-css'  href='https://cdn.mmaweekly.com/wp-content/plugins/nextgen-gallery/products/photocrati_nextgen/modules/widget/static/widgets.css' type='text/css' media='all' />
<link rel='stylesheet' id='nextgen_basic_thumbnails_style-css'  href='https://cdn.mmaweekly.com/wp-content/plugins/nextgen-gallery/products/photocrati_nextgen/modules/nextgen_basic_gallery/static/thumbnails/nextgen_basic_thumbnails.css' type='text/css' media='all' />
<link rel='stylesheet' id='nextgen_basic_slideshow_style-css'  href='https://cdn.mmaweekly.com/wp-content/plugins/nextgen-gallery/products/photocrati_nextgen/modules/nextgen_basic_gallery/static/slideshow/ngg_basic_slideshow.css' type='text/css' media='all' />
<link rel='stylesheet' id='really_simple_share_style-css'  href='https://cdn.mmaweekly.com/wp-content/plugins/really-simple-facebook-twitter-share-buttons/style.css' type='text/css' media='all' />
<script type='text/javascript' src='https://cdn.mmaweekly.com/wp-includes/js/jquery/jquery.min.js' id='jquery-core-js'></script>
<script type='text/javascript' src='https://cdn.mmaweekly.com/wp-includes/js/jquery/jquery-migrate.min.js' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://cdn.mmaweekly.com/wp-content/themes/orion/js/owl_carousel/owl.carousel.min.js' id='owl_carousel-js'></script>
<link rel="https://api.w.org/" href="https://www.mmaweekly.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.mmaweekly.com/wp-json/wp/v2/posts/452867" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.mmaweekly.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://cdn.mmaweekly.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.7" />
<link rel='shortlink' href='https://www.mmaweekly.com/?p=452867' />
<link rel="alternate" type="application/json+oembed" href="https://www.mmaweekly.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.mmaweekly.com%2Fkevin-holland-steps-in-to-face-marvin-vettori-in-ufc-on-abc-2-main-event" />
<link rel="alternate" type="text/xml+oembed" href="https://www.mmaweekly.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.mmaweekly.com%2Fkevin-holland-steps-in-to-face-marvin-vettori-in-ufc-on-abc-2-main-event&#038;format=xml" />
<script type='text/javascript'>
	(function () {
		var pl_beacon = document.createElement('script');
		pl_beacon.type = 'text/javascript';
		pl_beacon.async = true;
		var host = 'https://www.mmaweekly.com';
		if ('https:' == document.location.protocol) {
			host = host.replace('http://', 'https://');
		}
		pl_beacon.src = host + '/' + 'fRVgeMZRM9VO' + '.js?ts=' + Math.floor((Math.random() * 100000) + 1);
		var first_script_tag = document.getElementsByTagName('script')[0];
		first_script_tag.parentNode.insertBefore(pl_beacon, first_script_tag);
	})();
</script><script type="text/javascript">
        //<![CDATA[
        
      !function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src="https://platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");
      
        //]]>
  		</script>	<!--[if IE 8]>
		<link rel="stylesheet" href="https://cdn.mmaweekly.com/wp-content/themes/orion/css/ie8.css" />
	<![endif]-->
	<!-- CSS Options -->
	<style type="text/css" media="screen">
		
		::-moz-selection {background:#000; color:#fff;}
		::selection {background:#000; color:#fff;}
		
				h1, h2, h3, h4, h5, h6, .headersearch .search-box input[type=text],
		.widget_calendar table#wp-calendar caption,
		input#submit, button[type="submit"], input[type="submit"],
		.etabs li a, .caption-carousel .title, .dropcap
		{
							font-family:'Oswald', Arial, Helvetica, sans-serif;
				font-weight: normal;
				
					}
		
		.flexmenu a, .noMainmenu
		{
							font-family:'Trebuchet MS', Helvetica, sans-serif;
				font-weight: normal;
				
					}
		
		body, .flexmenu.fm-lg>ul>li>ul>li a, textarea, .review-item h5, .review-post .title h5
		{
							font:13px/21px Verdana, Geneva, sans-serif;
				
					}
			
				body {
			background:#ffffff;
		}
		
		.header-logo a, .header-adds a{
			line-height:120px;
		}
		.line-head, .etabs li a:hover, .etabs li.active a, 
		.widgettitle, .widgettitle:before,
		.pagination .pagi.current,
		.footerwidgettitle,
		.about-social li a,
		.owl_carousel .owl-controls.clickable .owl-buttons div:hover, 
		.comment-navigation div a:hover, 
		.single-nav a:hover,
		.review-final-score,
		.review-percentage .review-item .bar,
		input#submit, button[type="submit"], input[type="submit"],
		.single-tags h5, .edit-link a:hover,
		.dropcap.style1,
		.wpb_content_element .wpb_tabs_nav li,
		.counter-button,
		.tagcloud a span,
		.more-block:hover a, .more-block:hover .format,
		#back-top a 
		{
			background-color:#000000;
		}
		a:hover,
		a h1:hover, a h2:hover, a h3:hover, a h4:hover, a h5:hover, a h6:hover,
		.lists-category li a:hover, 
		.lists-category .all-category, 
		.lists-category .all-category a,
		.detailholder.medium .detailmeta a:hover,
		.counter-desc .count:hover,
		.about-social li a:hover,
		.owl_carousel .owl-controls .owl-buttons div, 
		.comment-navigation div a, 
		.single-nav a,
		.pagination .pagi,
		.single-tags .tags a:hover,
		.author-title-social .author-social a:hover,
		input#submit:hover, 
		button[type="submit"]:hover, 
		input[type="submit"]:hover,
		.headersearch-button i:hover,
		.single-content a,
		.dropcap.style2,
		.dropcap.style3,
		.dropcap.style4	{
			color:#000000;
		}
		.block-title h2, .comment-reply-title span, .footer, .footer-wrap.dark .footer{
			border-bottom-color:#000000;
		}
		.etabs li.active{
			border-top-color:#000000;
		}
		.single-content blockquote{
			border-left-color:#000000;
		}
		.about-social li a,
		.pagination .pagi.current,
		.owl_carousel .owl-controls .owl-buttons div, 
		.comment-navigation div a, 
		.single-nav a,
		.pagination .pagi,
		input#submit, button[type="submit"], input[type="submit"],
		.dropcap.style1,
		.dropcap.style2,
		.dropcap.style4,
		.wpb_content_element .wpb_tabs_nav li,
		.counter-button,
		.more-block:hover a, .more-block:hover .format{
			border-color:#000000;
		}
		
		.ticker-wrap{
			background-color:#111111;
		}
		
		.mediaholder .point-final-score
		{
			background-color:#111111;
		}
			</style>
<script type='text/javascript'>
/* <![CDATA[ */
var taqyeem = {"ajaxurl":"https://www.mmaweekly.com/wp-admin/admin-ajax.php" , "your_rating":"Your Rating :"};
/* ]]> */
</script>

<meta name="generator" content="Powered by Visual Composer - drag and drop page builder for WordPress."/>
<!--[if lte IE 9]><link rel="stylesheet" type="text/css" href="https://cdn.mmaweekly.com/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css" media="screen"><![endif]--><!--[if IE  8]><link rel="stylesheet" type="text/css" href="https://cdn.mmaweekly.com/wp-content/plugins/js_composer/assets/css/vc-ie8.min.css" media="screen"><![endif]--><link rel="icon" href="https://cdn.mmaweekly.com/wp-content/uploads/2016/09/cropped-New-Social-Networking-Icon-2012-512px-32x32.png" sizes="32x32" />
<link rel="icon" href="https://cdn.mmaweekly.com/wp-content/uploads/2016/09/cropped-New-Social-Networking-Icon-2012-512px-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://cdn.mmaweekly.com/wp-content/uploads/2016/09/cropped-New-Social-Networking-Icon-2012-512px-180x180.png" />
<meta name="msapplication-TileImage" content="https://cdn.mmaweekly.com/wp-content/uploads/2016/09/cropped-New-Social-Networking-Icon-2012-512px-270x270.png" />
<noscript><style type="text/css"> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript>	<script>
		(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
		(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
		m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
		})(window,document,'script','//www.google-analytics.com/analytics.js','ga');

		ga('create', 'UA-677267-1', 'auto');
		ga('send', 'pageview');

	</script>
	
	<meta name="google-site-verification" content="vJU2B3IyS9iXLyrXQNWKeqyLpSAnzdxZ-cwYUJlz32o" />
	
<!-- Facebook Pixel Code -->
<script>
!function(f,b,e,v,n,t,s)
{if(f.fbq)return;n=f.fbq=function(){n.callMethod?
n.callMethod.apply(n,arguments):n.queue.push(arguments)};
if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';
n.queue=[];t=b.createElement(e);t.async=!0;
t.src=v;s=b.getElementsByTagName(e)[0];
s.parentNode.insertBefore(t,s)}(window, document,'script',
'https://connect.facebook.net/en_US/fbevents.js');
fbq('init', '3625688447450213');
fbq('track', 'PageView');
</script>
<noscript><img height="1" width="1" style="display:none"
src="https://www.facebook.com/tr?id=3625688447450213&ev=PageView&noscript=1"
/></noscript>
<!-- End Facebook Pixel Code -->	
	
</head>

<body class="post-template-default single single-post postid-452867 single-format-standard wpb-js-composer js-comp-ver-4.12.1 vc_responsive">


<div id="siteContentSec">

<!-- <div class="section-wrap"> -->

		<!-- SECTION TOP HEADER -->
		<div class="top-header-wrap clearfix"> 
			
		</div>
		<!-- SECTION HEADER -->
		<div class="header-wrap clearfix"> 
			<div class="container">
				<div class="header row-fluid clearfix"> 
											
					<!-- Header Logo-->
					<div class="header-logo span12">
												<a href="https://www.mmaweekly.com">
							<span class="line-heads"></span>							<img src="https://cdn.mmaweekly.com/wp-content/uploads/2018/12/MMAWeekly-mma-news-logo-7k.png" alt="MMAWeekly.com" width="360px"/>
						</a>
					</div>
					
									</div>
			</div>
			<div class="navigation">
				<div class="container">
					<div class="row-fluid"> 
						<div class="span12"> 
							<!-- Header Navigation -->
							<div class="nav-container clearfix"> 
								<div class="nav-load clearfix"> 
									<div class="fm-button">
										<span class="fm-bar"></span>
										<span class="fm-bar"></span>
										<span class="fm-bar"></span>
									</div>
									<div class="nav-wrap">
										<ul id="main_menu" class="menu"><li id="menu-item-255891" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-255891"><a href="https://www.mmaweekly.com">Home</a></li>
<li id="menu-item-363955" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-363955"><a href="#">News</a>
<ul class="sub-menu">
	<li id="menu-item-256171" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-256171"><a href="https://www.mmaweekly.com/category/ufcnews">UFC News</a></li>
	<li id="menu-item-256169" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-256169"><a href="https://www.mmaweekly.com/category/news">MMA News</a></li>
	<li id="menu-item-395521" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-395521"><a title="Asian MMA News" href="https://asianmma.com">Asian MMA News</a></li>
	<li id="menu-item-256170" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-256170"><a href="https://www.mmaweekly.com/category/press-release-2">Press Releases</a></li>
</ul>
</li>
<li id="menu-item-256172" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-256172"><a href="https://www.mmaweekly.com/rumors">Events</a></li>
<li id="menu-item-398423" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-398423"><a title="UFC-MMA Betting Odds" href="https://record.webpartners.co/_l67-Ms-ZybdpLtekF-chNmNd7ZgqdRLk/1/">UFC &#8211; MMA Odds</a></li>
<li id="menu-item-363957" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-363957"><a href="#">Videos/Podcasts</a>
<ul class="sub-menu">
	<li id="menu-item-256166" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-256166"><a href="https://www.mmaweekly.com/category/video">Video</a></li>
	<li id="menu-item-256168" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-256168"><a href="https://www.mmaweekly.com/category/podcast-2">Podcasts</a></li>
	<li id="menu-item-256167" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-256167"><a href="https://www.mmaweekly.com/category/photos">Photos</a></li>
</ul>
</li>
<li id="menu-item-255916" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-255916"><a href="https://www.mmaweekly.com/hot-sauce">Hot Sauce</a></li>
<li id="menu-item-255922" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-255922"><a href="https://www.mmaweekly.com/media/ring-girl-gallery">Ring Girls</a></li>
</ul>									</div>	
									
									<a href="" class="headersearch-button"><i class="icon-search"></i></a>
									
									<div class="headersearch">
										<i class="icon-search bg"></i>
										<div class="search-box">
		<form action="https://www.mmaweekly.com" method="GET">
			<input type="text" name="s" id="s" value="Typing Here and Press Enter ..." placeholder="Typing Here and Press Enter ..." />
		</form>	      
</div>									</div>
								</div>
							</div>
						</div>
					</div>
				</div>
			</div>

<!-- Begin Sortable 728x90 Responsive Leaderboard -->
<div class="ad-tag" data-ad-name="ATF_Leaderboard_Responsive" data-ad-size="auto" ></div>
<script src="//tags-cdn.deployads.com/a/mmaweekly.com.js" async ></script>
<script>(deployads = window.deployads || []).push({});</script>
<!-- End Sortable 728x90 Responsive Leaderboard -->			

						<div class="headlinenews">
				<div class="container">
					<div class="row-fluid"> 
						<div class="span12"> 
								<div class="ticker-wrap clearfix">
		<span class="titleticker">
			HOT OFF THE WIRE
		</span>
		<div class="ticker_container">
			<div class="marquee-wrapper">
				<div class="marquee" id="marquee">
											<div class="marquee-list">
							<a href="https://www.mmaweekly.com/kevin-holland-steps-in-to-face-marvin-vettori-in-ufc-on-abc-2-main-event">Kevin Holland steps in to face Marvin Vettori in UFC on ABC 2 main event</a>
							<span>&#40;April 1&#41;</span>
						</div>
											<div class="marquee-list">
							<a href="https://www.mmaweekly.com/endeavor-upping-ufc-ownership-to-100-ahead-of-going-public">Endeavor upping UFC ownership to 100% ahead of going public</a>
							<span>&#40;April 1&#41;</span>
						</div>
											<div class="marquee-list">
							<a href="https://www.mmaweekly.com/ufc-260-fight-motion-francis-ngannou-folds-stipe-miocic">UFC 260 Fight Motion: Francis Ngannou folds Stipe Miocic</a>
							<span>&#40;March 31&#41;</span>
						</div>
									</div>
			</div>
			
		</div>
	</div>
 
						</div>
					</div>
				</div>
			</div>
					</div>
		<div class="container">	<div class="carousel-wrap clearfix">
			<div class="latest-carousel block4">	
				<div class="owl_carousel" data-grid="4" data-speed="1000">	
										<div class="post-452815 latest-carousel-item">
						<div class="mediaholder">
							<a href="https://www.mmaweekly.com/jon-jones-has-ufc-meeting-over-francis-ngannou-8-to-10-million-isnt-going-to-cut-it"><img width="440" height="310" src="https://cdn.mmaweekly.com/wp-content/uploads/2019/06/Jon-Jones-UFC239mediaday-750-440x310.jpg" class="attachment-block4-three size-block4-three wp-post-image" alt="Jon Jones at UFC 239" loading="lazy" srcset="https://cdn.mmaweekly.com/wp-content/uploads/2019/06/Jon-Jones-UFC239mediaday-750-440x310.jpg 440w, https://cdn.mmaweekly.com/wp-content/uploads/2019/06/Jon-Jones-UFC239mediaday-750-100x70.jpg 100w" sizes="(max-width: 440px) 100vw, 440px" /></a><h2>featured<a href="https://www.mmaweekly.com/jon-jones-has-ufc-meeting-over-francis-ngannou-8-to-10-million-isnt-going-to-cut-it">Jon Jones has UFC meeting over Francis Ngannou; $8 to $10 million isn&#8217;t going to cut it</a></h2>						</div>
					</div>
					
					
										<div class="post-452772 latest-carousel-item">
						<div class="mediaholder">
							<a href="https://www.mmaweekly.com/jon-jones-asks-to-be-released-then-deletes-twitter-posts"><img width="440" height="310" src="https://cdn.mmaweekly.com/wp-content/uploads/2020/02/Jon-Jones-UFC-247-post-fight-v2-440x310.jpg" class="attachment-block4-three size-block4-three wp-post-image" alt="Jon Jones UFC 247 post-fight" loading="lazy" srcset="https://cdn.mmaweekly.com/wp-content/uploads/2020/02/Jon-Jones-UFC-247-post-fight-v2-440x310.jpg 440w, https://cdn.mmaweekly.com/wp-content/uploads/2020/02/Jon-Jones-UFC-247-post-fight-v2-100x70.jpg 100w" sizes="(max-width: 440px) 100vw, 440px" /></a><h2>featured<a href="https://www.mmaweekly.com/jon-jones-asks-to-be-released-then-deletes-twitter-posts">Jon Jones asks UFC to be released, then deletes Twitter posts</a></h2>						</div>
					</div>
					
					
										<div class="post-452740 latest-carousel-item">
						<div class="mediaholder">
							<a href="https://www.mmaweekly.com/francis-ngannou-wants-to-fight-jon-jones-despite-dana-whites-doubts"><img width="440" height="310" src="https://cdn.mmaweekly.com/wp-content/uploads/2021/03/Francis-Ngannou-01-440x310.jpg" class="attachment-block4-three size-block4-three wp-post-image" alt="Francis Ngannou at UFC 260 post-fight with belt" loading="lazy" srcset="https://cdn.mmaweekly.com/wp-content/uploads/2021/03/Francis-Ngannou-01-440x310.jpg 440w, https://cdn.mmaweekly.com/wp-content/uploads/2021/03/Francis-Ngannou-01-100x70.jpg 100w" sizes="(max-width: 440px) 100vw, 440px" /></a><h2>featured<a href="https://www.mmaweekly.com/francis-ngannou-wants-to-fight-jon-jones-despite-dana-whites-doubts">Francis Ngannou wants to fight Jon Jones, despite Dana White’s doubts</a></h2>						</div>
					</div>
					
					
										<div class="post-452735 latest-carousel-item">
						<div class="mediaholder">
							<a href="https://www.mmaweekly.com/jon-jones-fires-back-at-dana-white-doubting-his-desire-to-fight-francis-ngannou"><img width="440" height="310" src="https://cdn.mmaweekly.com/wp-content/uploads/2020/05/Dana-White-and-Jon-Jones-why-would-I-lie-440x310.jpg" class="attachment-block4-three size-block4-three wp-post-image" alt="Dana White and Jon Jones - why would I lie" loading="lazy" srcset="https://cdn.mmaweekly.com/wp-content/uploads/2020/05/Dana-White-and-Jon-Jones-why-would-I-lie-440x310.jpg 440w, https://cdn.mmaweekly.com/wp-content/uploads/2020/05/Dana-White-and-Jon-Jones-why-would-I-lie-100x70.jpg 100w" sizes="(max-width: 440px) 100vw, 440px" /></a><h2>featured<a href="https://www.mmaweekly.com/jon-jones-fires-back-at-dana-white-doubting-his-desire-to-fight-francis-ngannou">Jon Jones fires back at Dana White doubting his desire to fight Francis Ngannou</a></h2>						</div>
					</div>
					
					
									</div>
			</div>
	</div>
 <div class="row-fluid">														<div id="post-452867" class="span8 single-page post-452867 post type-post status-publish format-standard has-post-thumbnail hentry category-frontpage category-news category-trending-ufc-mma-news category-ufcnews tag-darren-till tag-kevin-holland tag-marvin-vettori tag-ufc tag-ufc-las-vegas-23 tag-ufc-news tag-ufc-on-abc-2" >														<div class="block-title clearfix">																				<h2>Kevin Holland steps in to face Marvin Vettori in UFC on ABC 2 main event</h2>																	<!--<div class="single-navs">							<div class="single-nav nav-prev">								<a href="https://www.mmaweekly.com/bellator-255-streams-live-on-mmaweekly-com" rel="prev"><i class="icon-angle-left"></i></a>							</div>							<div class="single-nav nav-next">															</div>						</div> 	-->										</div>																																


						<div class="single-meta clearfix">					<div class="date"><i class="icon-calendar"></i>April 1, 2021</div>					<div class="comments spot-im-replies-count" data-min-count="1" data-placeholder-class="mma-num-replies" data-post-id="452867"><i class="icon-comments"></i><a href="https://www.mmaweekly.com/kevin-holland-steps-in-to-face-marvin-vettori-in-ufc-on-abc-2-main-event#comments"><span class="no-comments">No</span><span class="mma-num-replies">No</span>&nbsp;Comments</a></div>						<div class="author"><i class="icon-user"></i><a href="https://www.mmaweekly.com/author/hunter-brownstein" title="Posts by Hunter Brownstein" rel="author">Hunter Brownstein</a></div>			<div class="category"><ul class="about-social clearfix" style="margin-top:0px !important;"><li><span class="fb-share-button" data-width="90" data-type="button_count"></span></li><li><span><a href="https://twitter.com/share" class="twitter-share-button" data-count="horizontal" data-text="Share" data-url="https://www.mmaweekly.com/kevin-holland-steps-in-to-face-marvin-vettori-in-ufc-on-abc-2-main-event" ></a></span></li></ul> 
</div>				</div>				

<div class="single-media clearfix"><div class="single-image mediaholder">

 <img width="100%" src="https://cdn.mmaweekly.com/wp-content/uploads/2020/11/Kevin-Holland-750x370.jpg" title="Kevin Holland steps in to face Marvin Vettori in UFC on ABC 2 main event" />
</div></div>
  
<!-- Begin Sortable BTF_Leaderboard_Respoonsive (responsive 728x90, 300x250) -->
	<div class="ad-tag" data-ad-name="BTF_Leaderboard_Respoonsive" data-ad-size="auto" ></div>
<script src="//tags-cdn.deployads.com/a/mmaweekly.com.js" async ></script>
<script>(deployads = window.deployads || []).push({});</script>
	<p> </p>
<!-- End Sortable BTF_Leaderboard_Respoonsive -->

	<div class="single-content clearfix">				
<p>After pondering a potential move to welterweight, no. 10 ranked middleweight <a href="https://www.mmaweekly.com/tag/kevin-holland">Kevin Holland</a> will be competing in his second main event in three weeks, taking on no. 6 ranked welterweight Marvin Vettori in the main event of UFC on ABC 2.<br /><br />Holland replaces the injured <a href="https://www.mmaweekly.com/tag/darren-till">Darren Till</a>. The no. 5 ranked middleweight was forced to pull out Tuesday after he suffered a broken collarbone.<br /><br />Just eight minutes after Vettori sent a disgruntled tweet in response to Till pulling out of the fight, Holland responded on Twitter with his trademark phrase, “call big mouth”.</p>



<blockquote class="twitter-tweet"><p lang="en" dir="ltr">I already accepted the fight an hour ago&#8230;.. <a href="https://twitter.com/hashtag/callbigmouth?src=hash&amp;ref_src=twsrc%5Etfw">#callbigmouth</a> <a href="https://t.co/xY7viueXZ2">https://t.co/xY7viueXZ2</a> <a href="https://t.co/6ETxLKOF2f">pic.twitter.com/6ETxLKOF2f</a></p>&mdash; Kevin Holland (@Trailblaze2top) <a href="https://twitter.com/Trailblaze2top/status/1376992756506169347?ref_src=twsrc%5Etfw">March 30, 2021</a></blockquote> <script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script> 



<p>Vettori responded encouragingly, not long after responding by saying “let’s go”.</p>



<blockquote class="twitter-tweet"><p lang="en" dir="ltr">Let’s go</p>&mdash; Marvin Vettori (@MarvinVettori) <a href="https://twitter.com/MarvinVettori/status/1376994663987511297?ref_src=twsrc%5Etfw">March 30, 2021</a></blockquote> <script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script> 



<p><strong>TRENDING > <a href="https://www.mmaweekly.com/jon-jones-has-ufc-meeting-over-francis-ngannou-8-to-10-million-isnt-going-to-cut-it">Jon Jones has UFC meeting over Francis Ngannou; $8 to $10 million isn’t going to cut it</a></strong></p>



<p>This fight will be Holland’s seventh fight in just 11 months. “Trailblazer” was on a five fight win streak before losing a five round decision to no. 4 ranked middleweight Derek Brunson in the main event of UFC Vegas 22.<br /><br />Holland now has an opportunity to climb even higher in the middleweight <a href="https://www.ufc.com/rankings">division rankings</a>.<br /><br />Vettori on the other hand is on a four fight win streak, with his last loss coming as a split decision to none other than UFC middleweight champion <a href="https://www.mmaweekly.com/tag/israel-adesanya">Israel Adesanya</a>.<br /><br />“The Italian Dream” is coming off a career-defining short notice victory over no. 7 ranked middleweight Jack Hermansson at UFC Vegas 16.<br /><br />Vegas’ current odds on the main event for UFC on ABC 2 currently has Vettori as a -275 favorite, while Holland is positioned as a +220 underdog (via <a href="https://www.bovada.lv/">Bovada)</a>.<br /><br />While Vettori had an opportunity to climb the middleweight rankings with his scrapped bout against Darren Till, one could imagine the Italian middleweight is certainly happy to have an opportunity to fight against one of the most interesting characters the UFC has seen in recent memory in Kevin Holland.</p>



<p>UFC on ABC 2 takes place on April 10 at the UFC Apex in Las Vegas.  </p>
<div style="min-height:33px;" class="really_simple_share really_simple_share_button robots-nocontent snap_nopreview"><div class="really_simple_share_twitter" style="width:100px;"><a href="https://twitter.com/share" class="twitter-share-button" data-count="horizontal"  data-text="Kevin Holland steps in to face Marvin Vettori in UFC on ABC 2 main event" data-url="https://www.mmaweekly.com/kevin-holland-steps-in-to-face-marvin-vettori-in-ufc-on-abc-2-main-event"  data-via=""   ></a></div><div class="really_simple_share_facebook_share_new" style="width:100px;"><div class="fb-share-button" data-href="https://www.mmaweekly.com/kevin-holland-steps-in-to-face-marvin-vettori-in-ufc-on-abc-2-main-event" data-type="button_count" data-width="100"></div></div></div>
		<div class="really_simple_share_clearfix"></div> 									</div>					
	  
<!-- Begin BTF_Leaderboard_Respoonsive 2nd Placement LOWER (responsive 728x90, 300x250) -->
	<div class="ad-tag" data-ad-name="BTF_Leaderboard Responsive 728x90_300x250" data-ad-size="auto" ></div>
<script src="//tags-cdn.deployads.com/a/mmaweekly.com.js" async ></script>
<script>(deployads = window.deployads || []).push({});</script>
<p />
<!-- End BTF_Leaderboard_Respoonsive (responsive) -->
	
<!-- BEGIN Spot.IM Popular in Community & Comments -->
			<a name="comments"></a>			<div class="single-comments clearfix">				
<div data-spotim-module="recirculation" data-spot-id="sp_3qtDoO8S"></div>
<script src="https://recirculation.spot.im/spot/sp_3qtDoO8S"></script>
<script async src="https://launcher.spot.im/spot/sp_3qtDoO8S"
    data-spotim-module="spotim-launcher"
    data-post-id="452867"
    data-post-url="https://www.mmaweekly.com/kevin-holland-steps-in-to-face-marvin-vettori-in-ufc-on-abc-2-main-event"
    data-article-tags="Darren Till, Kevin Holland, Marvin Vettori, UFC, UFC Las Vegas 23, UFC news, UFC on ABC 2, frontpage, news, trending-ufc-mma-news, ufcnews"
	data-disqus-url="https://www.mmaweekly.com/kevin-holland-steps-in-to-face-marvin-vettori-in-ufc-on-abc-2-main-event"
    data-disqus-identifier="452867 https://www.mmaweekly.com/kevin-holland-steps-in-to-face-marvin-vettori-in-ufc-on-abc-2-main-event"></script>
<!-- END Spot.IM Popular in Community & Comments -->
	
<!-- Begin Taboola below article thumbnails -->  
<div id="taboola-below-article-thumbnails"></div>
<script type="text/javascript">
  window._taboola = window._taboola || [];
  _taboola.push({
    mode: 'thumbnails-a',
    container: 'taboola-below-article-thumbnails',
    placement: 'Below Article Thumbnails',
    target_type: 'mix'
  });
</script>
<!-- End Taboola below article thumbnails -->  
	
																					

	
	</div>		</div>
	
	
				<div class="sidebar span4">				<div id="custom_html-8" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><div class="ad-tag" data-ad-name="ATF_Halfpage_Responsive" data-ad-size="auto"></div>
<script src="//tags-cdn.deployads.com/a/mmaweekly.com.js" async></script>
<script>(deployads = window.deployads || []).push({});</script></div></div><div id="custom_html-3" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><script src="https://apis.google.com/js/platform.js"></script>
<center><div class="g-ytsubscribe" data-channelid="UC7tdFNggH_jwjJTDWqYelmA" data-layout="full" data-theme="dark" data-count="default"></div><p></p>
</center></div></div><div id="custom_html-23" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><center><a href="https://www.facebook.com/MMAWeeklyOfficial/" target="_blank" rel="noopener"><img src="https://cdn.mmaweekly.com/wp-content/uploads/2014/08/facebook.png" alt="facebook" width="32px" height="32px" /></a>&emsp; &emsp; <a href="https://twitter.com/mmaweeklycom" target="_blank" rel="noopener"><img src="https://cdn.mmaweekly.com/wp-content/uploads/2014/08/twitter.png" alt="twitter" width="32px" height="32px" /></a>&emsp; &emsp; <a href="https://instagram.com/mmaweekly" target="_blank" rel="noopener"><img src="https://cdn.mmaweekly.com/wp-content/uploads/2014/08/instagram.png" alt="instagram" width="32px" height="32px" /></a>&emsp; &emsp; <a href="/feed"><img src="https://cdn.mmaweekly.com/wp-content/uploads/2014/08/rss.png" alt="rss" width="32px" height="32px" /></a><p></p></center></div></div><div id="posts-widget-2" class="widget posts-widget"><h2 class="widgettitle">Hot Topics</h2><div class="widget-block">			
			<div class="small-post first clearfix">
				<div class="mediaholder small"><div class="caption-link"><a href="https://cdn.mmaweekly.com/wp-content/uploads/2021/04/Bellator-255-Live-Stream.jpg" title="" class="show-image caption-type first"><i class="icon-search"></i></a><a href="https://www.mmaweekly.com/bellator-255-streams-live-on-mmaweekly-com" title="Bellator 255 Streams Live on MMAWeekly.com"><i class="icon-plus"></i></a></div><a href="https://www.mmaweekly.com/bellator-255-streams-live-on-mmaweekly-com" title=""><img width="100" height="70" src="https://cdn.mmaweekly.com/wp-content/uploads/2021/04/Bellator-255-Live-Stream-100x70.jpg" class="attachment-mediaholder-small size-mediaholder-small wp-post-image" alt="Bellator 255 Live Stream" loading="lazy" srcset="https://cdn.mmaweekly.com/wp-content/uploads/2021/04/Bellator-255-Live-Stream-100x70.jpg 100w, https://cdn.mmaweekly.com/wp-content/uploads/2021/04/Bellator-255-Live-Stream-440x310.jpg 440w" sizes="(max-width: 100px) 100vw, 100px" /></a></div><div class="detailholder small"><h3><a href="https://www.mmaweekly.com/bellator-255-streams-live-on-mmaweekly-com" title="Bellator 255 Streams Live on MMAWeekly.com">Bellator 255 Streams Live on MMAWeekly.com</a></h3><div class="detailmeta"><p></p></div></div>			</div>
		
					
			<div class="small-post clearfix">
				<div class="mediaholder small"><div class="caption-link"><a href="https://cdn.mmaweekly.com/wp-content/uploads/2019/02/UFC-Prague-Twitter.jpg" title="" class="show-image caption-type first"><i class="icon-search"></i></a><a href="https://www.mmaweekly.com/endeavor-upping-ufc-ownership-to-100-ahead-of-going-public" title="Endeavor upping UFC ownership to 100% ahead of going public"><i class="icon-plus"></i></a></div><a href="https://www.mmaweekly.com/endeavor-upping-ufc-ownership-to-100-ahead-of-going-public" title=""><img width="100" height="70" src="https://cdn.mmaweekly.com/wp-content/uploads/2019/02/UFC-Prague-Twitter-100x70.jpg" class="attachment-mediaholder-small size-mediaholder-small wp-post-image" alt="UFC Prague - O2 Arena" loading="lazy" srcset="https://cdn.mmaweekly.com/wp-content/uploads/2019/02/UFC-Prague-Twitter-100x70.jpg 100w, https://cdn.mmaweekly.com/wp-content/uploads/2019/02/UFC-Prague-Twitter-440x310.jpg 440w" sizes="(max-width: 100px) 100vw, 100px" /></a></div><div class="detailholder small"><h3><a href="https://www.mmaweekly.com/endeavor-upping-ufc-ownership-to-100-ahead-of-going-public" title="Endeavor upping UFC ownership to 100% ahead of going public">Endeavor upping UFC ownership to 100% ahead of going public</a></h3><div class="detailmeta"><p></p></div></div>			</div>
		
					
			<div class="small-post clearfix">
				<div class="mediaholder small"><div class="caption-link"><a href="https://cdn.mmaweekly.com/wp-content/uploads/2014/10/Nate-Diaz-003-UFC-125-750.jpg" title="" class="show-image caption-type first"><i class="icon-search"></i></a><a href="https://www.mmaweekly.com/nate-diaz-returns-to-face-leon-edwards-conor-mcgregor-chimes-in" title="Nate Diaz returns to face Leon Edwards; Conor McGregor chimes in"><i class="icon-plus"></i></a></div><a href="https://www.mmaweekly.com/nate-diaz-returns-to-face-leon-edwards-conor-mcgregor-chimes-in" title=""><img width="100" height="70" src="https://cdn.mmaweekly.com/wp-content/uploads/2014/10/Nate-Diaz-003-UFC-125-750-100x70.jpg" class="attachment-mediaholder-small size-mediaholder-small wp-post-image" alt="" loading="lazy" srcset="https://cdn.mmaweekly.com/wp-content/uploads/2014/10/Nate-Diaz-003-UFC-125-750-100x70.jpg 100w, https://cdn.mmaweekly.com/wp-content/uploads/2014/10/Nate-Diaz-003-UFC-125-750-440x310.jpg 440w" sizes="(max-width: 100px) 100vw, 100px" /></a></div><div class="detailholder small"><h3><a href="https://www.mmaweekly.com/nate-diaz-returns-to-face-leon-edwards-conor-mcgregor-chimes-in" title="Nate Diaz returns to face Leon Edwards; Conor McGregor chimes in">Nate Diaz returns to face Leon Edwards; Conor McGregor chimes in</a></h3><div class="detailmeta"><p></p></div></div>			</div>
		
					
			<div class="small-post clearfix">
				<div class="mediaholder small"><div class="caption-link"><a href="https://cdn.mmaweekly.com/wp-content/uploads/2019/06/Jon-Jones-UFC239mediaday-750.jpg" title="" class="show-image caption-type first"><i class="icon-search"></i></a><a href="https://www.mmaweekly.com/jon-jones-has-ufc-meeting-over-francis-ngannou-8-to-10-million-isnt-going-to-cut-it" title="Jon Jones has UFC meeting over Francis Ngannou; $8 to $10 million isn&#8217;t going to cut it"><i class="icon-plus"></i></a></div><a href="https://www.mmaweekly.com/jon-jones-has-ufc-meeting-over-francis-ngannou-8-to-10-million-isnt-going-to-cut-it" title=""><img width="100" height="70" src="https://cdn.mmaweekly.com/wp-content/uploads/2019/06/Jon-Jones-UFC239mediaday-750-100x70.jpg" class="attachment-mediaholder-small size-mediaholder-small wp-post-image" alt="Jon Jones at UFC 239" loading="lazy" srcset="https://cdn.mmaweekly.com/wp-content/uploads/2019/06/Jon-Jones-UFC239mediaday-750-100x70.jpg 100w, https://cdn.mmaweekly.com/wp-content/uploads/2019/06/Jon-Jones-UFC239mediaday-750-440x310.jpg 440w" sizes="(max-width: 100px) 100vw, 100px" /></a></div><div class="detailholder small"><h3><a href="https://www.mmaweekly.com/jon-jones-has-ufc-meeting-over-francis-ngannou-8-to-10-million-isnt-going-to-cut-it" title="Jon Jones has UFC meeting over Francis Ngannou; $8 to $10 million isn&#8217;t going to cut it">Jon Jones has UFC meeting over Francis Ngannou; $8 to $10 million isn&#8217;t going to cut...</a></h3><div class="detailmeta"><p></p></div></div>			</div>
		
					
			<div class="small-post last clearfix">
				<div class="mediaholder small"><div class="caption-link"><a href="https://cdn.mmaweekly.com/wp-content/uploads/2019/11/Darren-Till-UFC-244-post-fight-press-conference.jpg" title="" class="show-image caption-type first"><i class="icon-search"></i></a><a href="https://www.mmaweekly.com/darren-till-out-of-ufc-on-abc-2-headliner" title="Darren Till out of UFC on ABC 2 headliner"><i class="icon-plus"></i></a></div><a href="https://www.mmaweekly.com/darren-till-out-of-ufc-on-abc-2-headliner" title=""><img width="100" height="70" src="https://cdn.mmaweekly.com/wp-content/uploads/2019/11/Darren-Till-UFC-244-post-fight-press-conference-100x70.jpg" class="attachment-mediaholder-small size-mediaholder-small wp-post-image" alt="Darren Till UFC 244 post-fight press conference" loading="lazy" srcset="https://cdn.mmaweekly.com/wp-content/uploads/2019/11/Darren-Till-UFC-244-post-fight-press-conference-100x70.jpg 100w, https://cdn.mmaweekly.com/wp-content/uploads/2019/11/Darren-Till-UFC-244-post-fight-press-conference-440x310.jpg 440w" sizes="(max-width: 100px) 100vw, 100px" /></a></div><div class="detailholder small"><h3><a href="https://www.mmaweekly.com/darren-till-out-of-ufc-on-abc-2-headliner" title="Darren Till out of UFC on ABC 2 headliner">Darren Till out of UFC on ABC 2 headliner</a></h3><div class="detailmeta"><p></p></div></div>			</div>
		
		</div></div><div id="posts-widget-6" class="widget posts-widget"><h2 class="widgettitle">Hot Sauce</h2><div class="widget-block">			
			<div class="small-post first clearfix">
				<div class="mediaholder small"><div class="caption-link"><a href="https://cdn.mmaweekly.com/wp-content/uploads/2019/05/anderson-silva-celebration-750.jpg" title="" class="show-image caption-type first"><i class="icon-search"></i></a><a href="https://www.mmaweekly.com/anderson-silva-to-box-julio-caesar-chavez-jr-on-june-19-in-mexico" title="Anderson Silva to box Julio Caesar Chavez, Jr. on June 19 in Mexico"><i class="icon-plus"></i></a></div><a href="https://www.mmaweekly.com/anderson-silva-to-box-julio-caesar-chavez-jr-on-june-19-in-mexico" title=""><img width="100" height="70" src="https://cdn.mmaweekly.com/wp-content/uploads/2019/05/anderson-silva-celebration-750-100x70.jpg" class="attachment-mediaholder-small size-mediaholder-small wp-post-image" alt="Anderson Silva" loading="lazy" srcset="https://cdn.mmaweekly.com/wp-content/uploads/2019/05/anderson-silva-celebration-750-100x70.jpg 100w, https://cdn.mmaweekly.com/wp-content/uploads/2019/05/anderson-silva-celebration-750-440x310.jpg 440w" sizes="(max-width: 100px) 100vw, 100px" /></a></div><div class="detailholder small"><h3><a href="https://www.mmaweekly.com/anderson-silva-to-box-julio-caesar-chavez-jr-on-june-19-in-mexico" title="Anderson Silva to box Julio Caesar Chavez, Jr. on June 19 in Mexico">Anderson Silva to box Julio Caesar Chavez, Jr. on June 19 in Mexico</a></h3><div class="detailmeta"><p></p></div></div>			</div>
		
					
			<div class="small-post clearfix">
				<div class="mediaholder small"><div class="caption-link"><a href="https://cdn.mmaweekly.com/wp-content/uploads/2021/03/paul-askren-presser-750.jpg" title="" class="show-image caption-type first"><i class="icon-search"></i></a><a href="https://www.mmaweekly.com/jake-paul-embarrasses-himself-against-ben-askren" title="Jake Paul embarrasses himself against Ben Askren"><i class="icon-plus"></i></a></div><a href="https://www.mmaweekly.com/jake-paul-embarrasses-himself-against-ben-askren" title=""><img width="100" height="70" src="https://cdn.mmaweekly.com/wp-content/uploads/2021/03/paul-askren-presser-750-100x70.jpg" class="attachment-mediaholder-small size-mediaholder-small wp-post-image" alt="" loading="lazy" srcset="https://cdn.mmaweekly.com/wp-content/uploads/2021/03/paul-askren-presser-750-100x70.jpg 100w, https://cdn.mmaweekly.com/wp-content/uploads/2021/03/paul-askren-presser-750-440x310.jpg 440w" sizes="(max-width: 100px) 100vw, 100px" /></a></div><div class="detailholder small"><h3><a href="https://www.mmaweekly.com/jake-paul-embarrasses-himself-against-ben-askren" title="Jake Paul embarrasses himself against Ben Askren">Jake Paul embarrasses himself against Ben Askren</a></h3><div class="detailmeta"><p></p></div></div>			</div>
		
					
			<div class="small-post clearfix">
				<div class="mediaholder small"><div class="caption-link"><a href="https://cdn.mmaweekly.com/wp-content/uploads/2021/03/Ben-Askren-face-palms-Jake-Paul.jpg" title="" class="show-image caption-type first"><i class="icon-search"></i></a><a href="https://www.mmaweekly.com/video-jake-paul-and-ben-askren-get-physical-at-fight-club-face-off" title="Video: Jake Paul and Ben Askren get physical at Fight Club face-off"><i class="icon-plus"></i></a></div><a href="https://www.mmaweekly.com/video-jake-paul-and-ben-askren-get-physical-at-fight-club-face-off" title=""><img width="100" height="70" src="https://cdn.mmaweekly.com/wp-content/uploads/2021/03/Ben-Askren-face-palms-Jake-Paul-100x70.jpg" class="attachment-mediaholder-small size-mediaholder-small wp-post-image" alt="Ben Askren face palms Jake Paul" loading="lazy" srcset="https://cdn.mmaweekly.com/wp-content/uploads/2021/03/Ben-Askren-face-palms-Jake-Paul-100x70.jpg 100w, https://cdn.mmaweekly.com/wp-content/uploads/2021/03/Ben-Askren-face-palms-Jake-Paul-440x310.jpg 440w" sizes="(max-width: 100px) 100vw, 100px" /></a></div><div class="detailholder small"><h3><a href="https://www.mmaweekly.com/video-jake-paul-and-ben-askren-get-physical-at-fight-club-face-off" title="Video: Jake Paul and Ben Askren get physical at Fight Club face-off">Video: Jake Paul and Ben Askren get physical at Fight Club face-off</a></h3><div class="detailmeta"><p></p></div></div>			</div>
		
					
			<div class="small-post clearfix">
				<div class="mediaholder small"><div class="caption-link"><a href="https://cdn.mmaweekly.com/wp-content/uploads/2020/01/Kamaru-Usman-and-Jorge-Masvidal.jpg" title="" class="show-image caption-type first"><i class="icon-search"></i></a><a href="https://www.mmaweekly.com/kamaru-usman-opens-as-heavy-favorite-in-jorge-masvidal-ufc-261-rematch" title="Kamaru Usman opens as heavy favorite in Jorge Masvidal UFC 261 rematch"><i class="icon-plus"></i></a></div><a href="https://www.mmaweekly.com/kamaru-usman-opens-as-heavy-favorite-in-jorge-masvidal-ufc-261-rematch" title=""><img width="100" height="70" src="https://cdn.mmaweekly.com/wp-content/uploads/2020/01/Kamaru-Usman-and-Jorge-Masvidal-100x70.jpg" class="attachment-mediaholder-small size-mediaholder-small wp-post-image" alt="Kamaru Usman and Jorge Masvidal" loading="lazy" srcset="https://cdn.mmaweekly.com/wp-content/uploads/2020/01/Kamaru-Usman-and-Jorge-Masvidal-100x70.jpg 100w, https://cdn.mmaweekly.com/wp-content/uploads/2020/01/Kamaru-Usman-and-Jorge-Masvidal-440x310.jpg 440w" sizes="(max-width: 100px) 100vw, 100px" /></a></div><div class="detailholder small"><h3><a href="https://www.mmaweekly.com/kamaru-usman-opens-as-heavy-favorite-in-jorge-masvidal-ufc-261-rematch" title="Kamaru Usman opens as heavy favorite in Jorge Masvidal UFC 261 rematch">Kamaru Usman opens as heavy favorite in Jorge Masvidal UFC 261 rematch</a></h3><div class="detailmeta"><p></p></div></div>			</div>
		
					
			<div class="small-post last clearfix">
				<div class="mediaholder small"><div class="caption-link"><a href="https://cdn.mmaweekly.com/wp-content/uploads/2021/03/Petr-Yan-knees-Aljamain-Sterling-at-UFC-259-Instagram.jpg" title="" class="show-image caption-type first"><i class="icon-search"></i></a><a href="https://www.mmaweekly.com/espn-releases-footage-of-petr-yans-corner-after-controversial-illegal-knee" title="ESPN releases footage of Petr Yan&#8217;s corner after controversial illegal knee"><i class="icon-plus"></i></a></div><a href="https://www.mmaweekly.com/espn-releases-footage-of-petr-yans-corner-after-controversial-illegal-knee" title=""><img width="100" height="70" src="https://cdn.mmaweekly.com/wp-content/uploads/2021/03/Petr-Yan-knees-Aljamain-Sterling-at-UFC-259-Instagram-100x70.jpg" class="attachment-mediaholder-small size-mediaholder-small wp-post-image" alt="Petr Yan knees Aljamain Sterling at UFC 259" loading="lazy" srcset="https://cdn.mmaweekly.com/wp-content/uploads/2021/03/Petr-Yan-knees-Aljamain-Sterling-at-UFC-259-Instagram-100x70.jpg 100w, https://cdn.mmaweekly.com/wp-content/uploads/2021/03/Petr-Yan-knees-Aljamain-Sterling-at-UFC-259-Instagram-440x310.jpg 440w" sizes="(max-width: 100px) 100vw, 100px" /></a></div><div class="detailholder small"><h3><a href="https://www.mmaweekly.com/espn-releases-footage-of-petr-yans-corner-after-controversial-illegal-knee" title="ESPN releases footage of Petr Yan&#8217;s corner after controversial illegal knee">ESPN releases footage of Petr Yan&#8217;s corner after controversial illegal knee</a></h3><div class="detailmeta"><p></p></div></div>			</div>
		
		</div></div><div id="custom_html-11" class="widget_text widget widget_custom_html"><h2 class="widgettitle">MMA Ring Girl Gallery</h2><div class="textwidget custom-html-widget"><center>
	<p style="text-align: center;"><em><strong><a style="color: #ff0000;" title="MMA Ring Girl Galleries" href="https://www.mmaweekly.com/media/ring-girl-gallery">Click an image below for Ring Girl Gallery</a></strong></em></p>
<a title="MMA Ring Girl Galleries" href="https://www.mmaweekly.com/media/ring-girl-gallery"><img class="aligncenter wp-image-285192" src="https://cdn.mmaweekly.com/wp-content/uploads/2018/01/2018-New-Ring-Girl-Graphic.jpg" alt="MMA Ring Girls" width="250" height="374" /></a>
</center></div></div>			</div>			</div> </div>
	
	<div class="footer-wrap clearfix">
		<div class="container">
			<div class="row-fluid">
				<div class="span12">
					<div class="footer-widget clearfix">
						<div class="row-fluid">
																	<!-- Widget 1 -->
		<div class="span4 first">
			<div id="custom_html-15" class="widget_text footer_widget widget_custom_html"><div class="textwidget custom-html-widget"><strong>MMAWEEKLY SOCIAL</strong><br />
<a href="https://www.facebook.com/MMAWeeklyOfficial">Follow MMAWeekly on Facebook</a><br />
<a href="https://twitter.com/#!/mmaweeklycom">Follow MMAWeekly on Twitter</a><br />
<a href="https://www.youtube.com/subscription_center?add_user=mmaweeklyvideos">Follow MMAWeekly on YouTube</a><br />
<hr />
<strong>PAGES</strong><br />
<a href="https://www.mmaweekly.com/">MMAWeekly.com Home</a><br />
<a href="https://www.mmaweekly.com/category/ufcnews">UFC News</a><br />
<a href="https://www.mmaweekly.com/news">MMA News</a><br />
<a href="https://www.mmaweekly.com/hot-sauce">MMA Hot Sauce Blog</a><br />
<a href="https://www.mmaweekly.com/rumors">MMA Rumors</a><br />
<a href="https://www.mmaweekly.com/category/video">MMA Videos</a><br />
<a href="https://www.mmaweekly.com/category/photos">MMA Photos</a><br />
<a href="https://www.mmaweekly.com/category/podcast-2">MMA Podcasts</a><br />
<a href="https://www.mmaweekly.com/contact-us">Contact Us</a><br />
<a href="https://www.mmaweekly.com/privacy">Privacy Policy</a><br /> </div></div>		</div>
			
		<!-- Widget 2 -->
		<div class="span4">
			<div id="custom_html-16" class="widget_text footer_widget widget_custom_html"><div class="textwidget custom-html-widget"><strong>UPCOMING EVENTS</strong><br />
<a title="UFC 235: Jones vs Smith Fight Card Rumors" href="/ufc-235-fight-card">UFC 235: Jones vs Smith</a><br /></div></div>		</div>
			
		<!-- Widget 3 -->
		<div class="span4 last">
			<div id="custom_html-17" class="widget_text footer_widget widget_custom_html"><div class="textwidget custom-html-widget"><strong>MORE SITES / BLOGS</strong><br />
<a href="http://sports.yahoo.com/ufc" target="_blank" rel="noopener">Yahoo! Sports</a><br />
<a href="http://bleacherreport.com/ufc" target="_blank" rel="noopener">Bleacher Report</a><br />
<a href="http://www.nerdcoremovement.com" target="_blank" rel="noopener">Nerdcore Movement</a><br />
<a href="https://asianmma.com" target="_blank" rel="noopener">Asian MMA</a><br /><a href="http://knockoutradio.com/" target="_blank" rel="noopener">Knockout Radio</a><br />
<a href="http://agfight.band.uol.com.br/en/" target="_blank" rel="noopener">AgFight</a><br />
<a href="http://www.fightline.com" target="_blank" rel="noopener">Fightline</a><br />
<a href="http://mmalinker.com/newsfeed" target="_blank" rel="noopener">MMA Linker</a><br />
<a href="http://www.addictedtomma.com/" target="_blank" rel="noopener">Addicted to MMA</a><br /></div></div>		</div>													</div>
					</div>

											<div class="footer clearfix">
																					<div class="footer-right">
								<div class="bottom-menu">
									<ul id="bottomNav" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-255891"><a href="https://www.mmaweekly.com">Home</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-has-children menu-item-363955"><a href="#">News</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-256172"><a href="https://www.mmaweekly.com/rumors">Events</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-398423"><a title="UFC-MMA Betting Odds" href="https://record.webpartners.co/_l67-Ms-ZybdpLtekF-chNmNd7ZgqdRLk/1/">UFC &#8211; MMA Odds</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-has-children menu-item-363957"><a href="#">Videos/Podcasts</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-255916"><a href="https://www.mmaweekly.com/hot-sauce">Hot Sauce</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-255922"><a href="https://www.mmaweekly.com/media/ring-girl-gallery">Ring Girls</a></li>
</ul>								</div>
							</div>
													</div>			
									</div>
			</div>
		</div>
	</div>
	<div id="back-top">
		<a href="#top"><span class="icon-long-arrow-up"></span></a>
	</div>
</div>


  <div id="fb-root"></div>
  <script>(function(d, s, id) {
    var js, fjs = d.getElementsByTagName(s)[0];
    if (d.getElementById(id)) return;
    js = d.createElement(s); js.id = id;
    js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.0";
    fjs.parentNode.insertBefore(js, fjs);
  }(document, 'script', 'facebook-jssdk'));</script>	<script type="text/javascript">
		jQuery(window).ready(function() {
			// Sticky Header
							jQuery('.navigation').stickyMenu();
						
			// Navigation
			jQuery('.nav-wrap').flexMenu({
									breakpoint: 962,
								responsivePattern: 'toggle',
				animationSpeed: 300
			});
		});
		
					(function(d, s, id) {
				var js, fjs = d.getElementsByTagName(s)[0];
				if (d.getElementById(id)) return;
				js = d.createElement(s); js.id = id;
				js.src = "//connect.facebook.net/en_US/all.js#xfbml=1&appId=102226266616709";
				fjs.parentNode.insertBefore(js, fjs);
			}
			(document, 'script', 'facebook-jssdk'));
			
			(function() {
				window.PinIt = window.PinIt || { loaded:false };
				if (window.PinIt.loaded) return;
				window.PinIt.loaded = true;
				function async_load(){
					var s = document.createElement("script");
					s.type = "text/javascript";
					s.async = true;
					s.src = "https://assets.pinterest.com/js/pinit.js";
					var x = document.getElementsByTagName("script")[0];
					x.parentNode.insertBefore(s, x);
				}
				if (window.attachEvent)
					window.attachEvent("onload", async_load);
				else
					window.addEventListener("load", async_load, false);
			})();
				
		var retina = window.devicePixelRatio > 1 ? true : false;

        		
				
		
	</script>
<script type='text/javascript' src='https://cdn.mmaweekly.com/wp-includes/js/comment-reply.min.js' id='comment-reply-js'></script>
<script type='text/javascript' src='https://cdn.mmaweekly.com/wp-content/themes/orion/js/jquery.placeholder-enhanced.min.js' id='placeholder-js'></script>
<script type='text/javascript' src='https://cdn.mmaweekly.com/wp-content/themes/orion/js/init.js' id='init-js'></script>
<script type='text/javascript' src='https://cdn.mmaweekly.com/wp-content/themes/orion/js/custom.js' id='custom-js'></script>
<script type='text/javascript' src='https://platform.twitter.com/widgets.js' id='twitter-js'></script>
<script type='text/javascript' src='https://cdn.mmaweekly.com/wp-includes/js/wp-embed.min.js' id='wp-embed-js'></script>

</div>


<!-- siteContentSec -->

<!-- Spot.IM Message-Count Script -->
<script src="https://app-cdn.spot.im/modules/messages-count/3.0.126/bundle.js" type="text/javascript" async defer></script>

<!-- Taboola Body Script -->
<script type="text/javascript">
  window._taboola = window._taboola || [];
  _taboola.push({flush: true});
</script>

</body>


<!-- Facebook Share Function Script -->
<div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.5";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>


</html>

<style>
.about-social li {

margin-bottom: 0px !important;
}
</style>