<!DOCTYPE html>
<!--[if IE 7]><html class="ie ie7" lang="en-US" xmlns:og="http://opengraphprotocol.org/schema/" xmlns:fb="http://www.facebook.com/2008/fbml"
	prefix="og: http://ogp.me/ns#" ><![endif]-->
<!--[if IE 8]><html class="ie ie8" lang="en-US" xmlns:og="http://opengraphprotocol.org/schema/" xmlns:fb="http://www.facebook.com/2008/fbml"
	prefix="og: http://ogp.me/ns#" ><![endif]-->
<!--[if !(IE 7) | !(IE 8)  ]><!--><html lang="en-US" xmlns:og="http://opengraphprotocol.org/schema/" xmlns:fb="http://www.facebook.com/2008/fbml"
	prefix="og: http://ogp.me/ns#" ><!--<![endif]-->

<head>
	
<!-- Begin Sortable header code for ad tags -->
<script src="//tags-cdn.deployads.com/a/mmaweekly.com.js" async ></script>
<!-- End Sortable header code for ad tags -->
  
<!-- Begin Taboola header code -->
<script type="text/javascript">
  window._taboola = window._taboola || [];
  _taboola.push({article:'auto'});
  !function (e, f, u, i) {
    if (!document.getElementById(i)){
      e.async = 1;
      e.src = u;
      e.id = i;
      f.parentNode.insertBefore(e, f);
    }
  }(document.createElement('script'),
  document.getElementsByTagName('script')[0],
  '//cdn.taboola.com/libtrc/mmaweeklycom-network/loader.js',
  'tb_loader_script');
  if(window.performance && typeof window.performance.mark == 'function')
    {window.performance.mark('tbl_ic');}
</script>
<!-- End Taboola header code -->
	
<link rel="preload" href="https://cdn.mmaweekly.com/wp-content/themes/orion/css/font-awesome/font/fontawesome-webfont.woff?v=3.2.1" as="font" type="font/woff2">
	
	<title>Brandon Royval expects to &#039;walk through&#039; LFA flyweights on way to UFC | MMAWeekly.com</title>
    <meta charset="UTF-8" />
    <meta http-equiv="Content-Type" content="text/html; charset=UTF-8">
	<link rel="pingback" href="https://www.mmaweekly.com/xmlrpc.php" />
			<meta name="viewport" content="width=device-width, initial-scale=1.0">
			
			<link rel="shortcut icon" href="https://cdn.mmaweekly.com/wp-content/uploads/2014/10/MMAWeekly-Favicon-16x16-Rounded.png" type="image/x-icon" />
		
			<!-- For iPhone -->
		<link rel="apple-touch-icon-precomposed" href="https://cdn.mmaweekly.com/wp-content/uploads/2014/10/MMAWeekly-Favicon-57x57-Rounded.png">
	
			<!-- For iPhone 4 Retina display -->
		<link rel="apple-touch-icon-precomposed" sizes="114x114" href="https://cdn.mmaweekly.com/wp-content/uploads/2014/10/MMAWeekly-Favicon-114x114-Rounded.png">
	
			<!-- For iPad -->
		<link rel="apple-touch-icon-precomposed" sizes="72x72" href="https://cdn.mmaweekly.com/wp-content/uploads/2014/10/MMAWeekly-Favicon-72x72-Rounded.png">
	
			<!-- For iPad Retina display -->
		<link rel="apple-touch-icon-precomposed" sizes="144x144" href="https://cdn.mmaweekly.com/wp-content/uploads/2014/10/MMAWeekly-Favicon-144x144-Rounded.png">
		
		
	
<!-- All in One SEO Pack 3.1.1 by Michael Torbert of Semper Fi Web Design[1566,1675] -->
<meta name="description"  content="Brandon Royval (9-4) will get his long-awaited title shot when he faces late replacement Nate Williams (29-18) in the LFA 79 main event in Denver on Friday." />

<meta name="keywords"  content="brandon royval,nate williams,legacy fighting alliance,mma news,lfa 79,front page,news" />

<link rel="canonical" href="https://www.mmaweekly.com/brandon-royval-expects-to-walk-through-lfa-flyweights-en-route-to-ufc" />
<meta property="og:title" content="Brandon Royval expects to &#039;walk through&#039; LFA flyweights on way to UFC | MMAWeekly.com" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.mmaweekly.com/brandon-royval-expects-to-walk-through-lfa-flyweights-en-route-to-ufc" />
<meta property="og:image" content="https://cdn.mmaweekly.com/wp-content/uploads/2019/11/Brandon-Royval-750.jpg" />
<meta property="og:site_name" content="MMAWeekly.com" />
<meta property="fb:admins" content="176775391774" />
<meta property="og:description" content="Brandon Royval (9-4) will get his long-awaited title shot when he faces late replacement Nate Williams (29-18) in the LFA 79 main event in Denver on Friday." />
<meta property="article:published_time" content="2019-11-20T19:06:48Z" />
<meta property="article:modified_time" content="2019-11-20T19:06:48Z" />
<meta property="og:image:secure_url" content="https://cdn.mmaweekly.com/wp-content/uploads/2019/11/Brandon-Royval-750.jpg" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@mmaweeklycom" />
<meta name="twitter:domain" content="MMAWeekly.com" />
<meta name="twitter:title" content="Brandon Royval expects to &#039;walk through&#039; LFA flyweights on way to UFC | MMAWeekly.com" />
<meta name="twitter:description" content="Brandon Royval (9-4) will get his long-awaited title shot when he faces late replacement Nate Williams (29-18) in the LFA 79 main event in Denver on Friday." />
<meta name="twitter:image" content="https://cdn.mmaweekly.com/wp-content/uploads/2019/11/Brandon-Royval-750.jpg" />
			<script type="text/javascript" >
				window.ga=window.ga||function(){(ga.q=ga.q||[]).push(arguments)};ga.l=+new Date;
				ga('create', 'UA-677267-1', { 'cookieDomain': 'www.mmaweekly.com' } );
				// Plugins
				
				ga('send', 'pageview');
			</script>
			<script async src="https://www.google-analytics.com/analytics.js"></script>
			<!-- All in One SEO Pack -->
<link rel='dns-prefetch' href='//platform.twitter.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="MMAWeekly.com &raquo; Feed" href="https://www.mmaweekly.com/feed" />
<link rel="alternate" type="application/rss+xml" title="MMAWeekly.com &raquo; Comments Feed" href="https://www.mmaweekly.com/comments/feed" />
<link rel="alternate" type="application/rss+xml" title="MMAWeekly.com &raquo; Brandon Royval expects to &#8216;walk through&#8217; LFA flyweights en route to UFC Comments Feed" href="https://www.mmaweekly.com/brandon-royval-expects-to-walk-through-lfa-flyweights-en-route-to-ufc/feed" />
<meta property="fb:admins" content="1293214633"/><meta property="og:title" content="Brandon Royval expects to &#8216;walk through&#8217; LFA flyweights en route to UFC"/><meta property="og:type" content="article"/><meta property="og:url" content="https://www.mmaweekly.com/brandon-royval-expects-to-walk-through-lfa-flyweights-en-route-to-ufc"/><meta property="og:site_name" content="MMAWeekly.com”/><meta property="og:image" content="https://cdn.mmaweekly.com/wp-content/uploads/2019/11/Brandon-Royval-750-375x185.jpg"/>
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/cdn.mmaweekly.com\/wp-includes\/js\/wp-emoji-release.min.js"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://cdn.mmaweekly.com/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='owl_stylesheet-css'  href='https://cdn.mmaweekly.com/wp-content/themes/orion/js/owl_carousel/assets/owl.carousel.css' type='text/css' media='all' />
<link rel='stylesheet' id='google_fonts-css'  href='https://fonts.googleapis.com/css?family=Lato%7COswald%7COswald%3A400%2C400italic%2C700%2C700italic&#038;subset=latin%2Cgreek-ext%2Ccyrillic%2Clatin-ext%2Cgreek%2Ccyrillic-ext%2Cvietnamese&#038;ver=5.2.4' type='text/css' media='all' />
<link rel='stylesheet' id='bootstrap-css'  href='https://cdn.mmaweekly.com/wp-content/themes/orion/css/bootstrap.css' type='text/css' media='all' />
<link rel='stylesheet' id='style-css'  href='https://cdn.mmaweekly.com/wp-content/themes/orion/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='awesome-css'  href='https://cdn.mmaweekly.com/wp-content/themes/orion/css/font-awesome/css/font-awesome.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='magnific-popup-css'  href='https://cdn.mmaweekly.com/wp-content/themes/orion/css/magnific-popup.css' type='text/css' media='all' />
<link rel='stylesheet' id='visual-composer-css'  href='https://cdn.mmaweekly.com/wp-content/themes/orion/css/visual-composer.css' type='text/css' media='all' />
<link rel='stylesheet' id='responsive-css'  href='https://cdn.mmaweekly.com/wp-content/themes/orion/css/responsive.css' type='text/css' media='all' />
<link rel='stylesheet' id='really_simple_share_style-css'  href='https://cdn.mmaweekly.com/wp-content/plugins/really-simple-facebook-twitter-share-buttons/style.css' type='text/css' media='all' />
<script type='text/javascript' src='https://cdn.mmaweekly.com/wp-includes/js/jquery/jquery.js'></script>
<script type='text/javascript' src='https://cdn.mmaweekly.com/wp-includes/js/jquery/jquery-migrate.min.js'></script>
<script type='text/javascript' src='https://cdn.mmaweekly.com/wp-content/themes/orion/js/owl_carousel/owl.carousel.min.js'></script>
<link rel='https://api.w.org/' href='https://www.mmaweekly.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.mmaweekly.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://cdn.mmaweekly.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='UFC Hall of Fame historic fight: Shogun Rua vs. Dan Henderson' href='https://www.mmaweekly.com/ufc-hall-of-fame-historic-fight-shogun-rua-vs-dan-henderson' />
<link rel='next' title='Ben Askren not using hip injury as excuse for UFC losses: &#8216;I lost because I wasn&#8217;t good enough&#8217;' href='https://www.mmaweekly.com/ben-askren-not-using-hip-injury-as-excuse-for-ufc-losses-i-lost-because-i-wasnt-good-enough' />
<meta name="generator" content="WordPress 5.2.4" />
<link rel='shortlink' href='https://www.mmaweekly.com/?p=428799' />
<link rel="alternate" type="application/json+oembed" href="https://www.mmaweekly.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.mmaweekly.com%2Fbrandon-royval-expects-to-walk-through-lfa-flyweights-en-route-to-ufc" />
<link rel="alternate" type="text/xml+oembed" href="https://www.mmaweekly.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.mmaweekly.com%2Fbrandon-royval-expects-to-walk-through-lfa-flyweights-en-route-to-ufc&#038;format=xml" />
<script type='text/javascript'>
	(function () {
		var pl_beacon = document.createElement('script');
		pl_beacon.type = 'text/javascript';
		pl_beacon.async = true;
		var host = 'https://www.mmaweekly.com';
		if ('https:' == document.location.protocol) {
			host = host.replace('http://', 'https://');
		}
		pl_beacon.src = host + '/fRVgeMZRM9VO.js?ts=' + Math.floor((Math.random() * 100000) + 1);
		var first_script_tag = document.getElementsByTagName('script')[0];
		first_script_tag.parentNode.insertBefore(pl_beacon, first_script_tag);
	})();
</script><script type="text/javascript">
        //<![CDATA[
        
      !function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src="https://platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");
      
        //]]>
  		</script><!-- <meta name="NextGEN" version="3.2.10" /> -->
	<!--[if IE 8]>
		<link rel="stylesheet" href="https://cdn.mmaweekly.com/wp-content/themes/orion/css/ie8.css" />
	<![endif]-->
	<!-- CSS Options -->
	<style type="text/css" media="screen">
		
		::-moz-selection {background:#000; color:#fff;}
		::selection {background:#000; color:#fff;}
		
				h1, h2, h3, h4, h5, h6, .headersearch .search-box input[type=text],
		.widget_calendar table#wp-calendar caption,
		input#submit, button[type="submit"], input[type="submit"],
		.etabs li a, .caption-carousel .title, .dropcap
		{
							font-family:'Oswald', Arial, Helvetica, sans-serif;
				font-weight: normal;
				
					}
		
		.flexmenu a, .noMainmenu
		{
							font-family:'Trebuchet MS', Helvetica, sans-serif;
				font-weight: normal;
				
					}
		
		body, .flexmenu.fm-lg>ul>li>ul>li a, textarea, .review-item h5, .review-post .title h5
		{
							font:13px/21px Verdana, Geneva, sans-serif;
				
					}
			
				body {
			background:#ffffff;
		}
		
		.header-logo a, .header-adds a{
			line-height:120px;
		}
		.line-head, .etabs li a:hover, .etabs li.active a, 
		.widgettitle, .widgettitle:before,
		.pagination .pagi.current,
		.footerwidgettitle,
		.about-social li a,
		.owl_carousel .owl-controls.clickable .owl-buttons div:hover, 
		.comment-navigation div a:hover, 
		.single-nav a:hover,
		.review-final-score,
		.review-percentage .review-item .bar,
		input#submit, button[type="submit"], input[type="submit"],
		.single-tags h5, .edit-link a:hover,
		.dropcap.style1,
		.wpb_content_element .wpb_tabs_nav li,
		.counter-button,
		.tagcloud a span,
		.more-block:hover a, .more-block:hover .format,
		#back-top a 
		{
			background-color:#000000;
		}
		a:hover,
		a h1:hover, a h2:hover, a h3:hover, a h4:hover, a h5:hover, a h6:hover,
		.lists-category li a:hover, 
		.lists-category .all-category, 
		.lists-category .all-category a,
		.detailholder.medium .detailmeta a:hover,
		.counter-desc .count:hover,
		.about-social li a:hover,
		.owl_carousel .owl-controls .owl-buttons div, 
		.comment-navigation div a, 
		.single-nav a,
		.pagination .pagi,
		.single-tags .tags a:hover,
		.author-title-social .author-social a:hover,
		input#submit:hover, 
		button[type="submit"]:hover, 
		input[type="submit"]:hover,
		.headersearch-button i:hover,
		.single-content a,
		.dropcap.style2,
		.dropcap.style3,
		.dropcap.style4	{
			color:#000000;
		}
		.block-title h2, .comment-reply-title span, .footer, .footer-wrap.dark .footer{
			border-bottom-color:#000000;
		}
		.etabs li.active{
			border-top-color:#000000;
		}
		.single-content blockquote{
			border-left-color:#000000;
		}
		.about-social li a,
		.pagination .pagi.current,
		.owl_carousel .owl-controls .owl-buttons div, 
		.comment-navigation div a, 
		.single-nav a,
		.pagination .pagi,
		input#submit, button[type="submit"], input[type="submit"],
		.dropcap.style1,
		.dropcap.style2,
		.dropcap.style4,
		.wpb_content_element .wpb_tabs_nav li,
		.counter-button,
		.more-block:hover a, .more-block:hover .format{
			border-color:#000000;
		}
		
		.ticker-wrap{
			background-color:#111111;
		}
		
		.mediaholder .point-final-score
		{
			background-color:#111111;
		}
			</style>
<script type='text/javascript'>
/* <![CDATA[ */
var taqyeem = {"ajaxurl":"https://www.mmaweekly.com/wp-admin/admin-ajax.php" , "your_rating":"Your Rating :"};
/* ]]> */
</script>

<meta name="generator" content="Powered by Visual Composer - drag and drop page builder for WordPress."/>
<!--[if lte IE 9]><link rel="stylesheet" type="text/css" href="https://cdn.mmaweekly.com/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css" media="screen"><![endif]--><!--[if IE  8]><link rel="stylesheet" type="text/css" href="https://cdn.mmaweekly.com/wp-content/plugins/js_composer/assets/css/vc-ie8.min.css" media="screen"><![endif]--><link rel="icon" href="https://cdn.mmaweekly.com/wp-content/uploads/2016/09/cropped-New-Social-Networking-Icon-2012-512px-32x32.png" sizes="32x32" />
<link rel="icon" href="https://cdn.mmaweekly.com/wp-content/uploads/2016/09/cropped-New-Social-Networking-Icon-2012-512px-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://cdn.mmaweekly.com/wp-content/uploads/2016/09/cropped-New-Social-Networking-Icon-2012-512px-180x180.png" />
<meta name="msapplication-TileImage" content="https://cdn.mmaweekly.com/wp-content/uploads/2016/09/cropped-New-Social-Networking-Icon-2012-512px-270x270.png" />
<noscript><style type="text/css"> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript>	<script>
		(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
		(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
		m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
		})(window,document,'script','//www.google-analytics.com/analytics.js','ga');

		ga('create', 'UA-677267-1', 'auto');
		ga('send', 'pageview');

	</script>
	
<!-- AdsPlus InRead Code -->
<center style="margin-bottom: 20px">
<script async src="https://cdn.ad.plus/player/adplus.js"></script>
<script>(function(){var i='DJfdqZ1LVmY50U7KeW3HN79uDvNoIEDKldvU3MRtGzeGsQrq3lGy';document.write('<div id="'+i+'"></div>');(playerPro=window.playerPro||[]).push(i);})();</script>
</center>
<!-- End AdsPlus InRead Code -->
  
<!-- Insticator Header Tag Code -->
<script data-cfasync='false' type='text/javascript'>/*<![CDATA[*/(function (a, c, s, u){'Insticator'in a || (a.Insticator={ad:{loadAd: function (b){Insticator.ad.q.push(b)}, q: []}, helper:{}, embed:{}, version: "3.0", q: [], load: function (t, o){Insticator.q.push({t: t, o: o})}}); var b=c.createElement(s); b.src=u; b.async=!0; var d=c.getElementsByTagName(s)[0]; d.parentNode.insertBefore(b, d)})(window, document, 'script', '//d2na2p72vtqyok.cloudfront.net/client-embed/59143dcd-5373-49d4-a5e6-353f08b8d871.js');/*]]>*/</script>
<!-- End Insticator Header Tag Code -->	
	
	<meta name="google-site-verification" content="vJU2B3IyS9iXLyrXQNWKeqyLpSAnzdxZ-cwYUJlz32o" />
	
</head>

<body class="post-template-default single single-post postid-428799 single-format-standard wpb-js-composer js-comp-ver-4.12.1 vc_responsive">


<div id="siteContentSec">

<!-- <div class="section-wrap"> -->

		<!-- SECTION TOP HEADER -->
		<div class="top-header-wrap clearfix"> 
			
		</div>
		<!-- SECTION HEADER -->
		<div class="header-wrap clearfix"> 
			<div class="container">
				<div class="header row-fluid clearfix"> 
											
					<!-- Header Logo-->
					<div class="header-logo span12">
												<a href="https://www.mmaweekly.com">
							<span class="line-heads"></span>							<img src="https://cdn.mmaweekly.com/wp-content/uploads/2018/12/MMAWeekly-mma-news-logo-7k.png" alt="MMAWeekly.com" width="360px"/>
						</a>
					</div>
					
									</div>
			</div>
			<div class="navigation">
				<div class="container">
					<div class="row-fluid"> 
						<div class="span12"> 
							<!-- Header Navigation -->
							<div class="nav-container clearfix"> 
								<div class="nav-load clearfix"> 
									<div class="fm-button">
										<span class="fm-bar"></span>
										<span class="fm-bar"></span>
										<span class="fm-bar"></span>
									</div>
									<div class="nav-wrap">
										<ul id="main_menu" class="menu"><li id="menu-item-255891" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-255891"><a href="https://www.mmaweekly.com/">Home</a></li>
<li id="menu-item-363955" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-363955"><a href="#">News</a>
<ul class="sub-menu">
	<li id="menu-item-256171" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-256171"><a href="https://www.mmaweekly.com/category/ufcnews">UFC News</a></li>
	<li id="menu-item-256169" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-256169"><a href="https://www.mmaweekly.com/category/news">MMA News</a></li>
	<li id="menu-item-395521" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-395521"><a title="Asian MMA News" href="https://asianmma.com">Asian MMA News</a></li>
	<li id="menu-item-256170" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-256170"><a href="https://www.mmaweekly.com/category/press-release-2">Press Releases</a></li>
</ul>
</li>
<li id="menu-item-256172" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-256172"><a href="https://www.mmaweekly.com/rumors">Events</a></li>
<li id="menu-item-398423" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-398423"><a title="UFC-MMA Betting Odds" href="https://record.webpartners.co/_l67-Ms-ZybdpLtekF-chNmNd7ZgqdRLk/1/">UFC &#8211; MMA Odds</a></li>
<li id="menu-item-363957" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-363957"><a href="#">Videos/Podcasts</a>
<ul class="sub-menu">
	<li id="menu-item-256166" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-256166"><a href="https://www.mmaweekly.com/category/video">Video</a></li>
	<li id="menu-item-256168" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-256168"><a href="https://www.mmaweekly.com/category/podcast-2">Podcasts</a></li>
	<li id="menu-item-256167" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-256167"><a href="https://www.mmaweekly.com/category/photos">Photos</a></li>
</ul>
</li>
<li id="menu-item-255916" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-255916"><a href="https://www.mmaweekly.com/hot-sauce">Hot Sauce</a></li>
<li id="menu-item-255922" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-255922"><a href="https://www.mmaweekly.com/media/ring-girl-gallery">Ring Girls</a></li>
</ul>									</div>	
									
									<a href="" class="headersearch-button"><i class="icon-search"></i></a>
									
									<div class="headersearch">
										<i class="icon-search bg"></i>
										<div class="search-box">
		<form action="https://www.mmaweekly.com" method="GET">
			<input type="text" name="s" id="s" value="Typing Here and Press Enter ..." placeholder="Typing Here and Press Enter ..." />
		</form>	      
</div>									</div>
								</div>
							</div>
						</div>
					</div>
				</div>
			</div>

<!-- Begin Sortable 728x90 Responsive Leaderboard -->
<div class="ad-tag" data-ad-name="ATF_Leaderboard_Responsive" data-ad-size="auto" ></div>
<script src="//tags-cdn.deployads.com/a/mmaweekly.com.js" async ></script>
<script>(deployads = window.deployads || []).push({});</script>
<!-- End Sortable 728x90 Responsive Leaderboard -->			

						<div class="headlinenews">
				<div class="container">
					<div class="row-fluid"> 
						<div class="span12"> 
								<div class="ticker-wrap clearfix">
		<span class="titleticker">
			HOT OFF THE WIRE
		</span>
		<div class="ticker_container">
			<div class="marquee-wrapper">
				<div class="marquee" id="marquee">
											<div class="marquee-list">
							<a href="https://www.mmaweekly.com/greg-hardy-among-several-lengthy-ufc-moscow-medical-supsensions">Greg Hardy among several lengthy UFC Moscow medical supsensions</a>
							<span>&#40;November 20&#41;</span>
						</div>
											<div class="marquee-list">
							<a href="https://www.mmaweekly.com/ben-askren-not-using-hip-injury-as-excuse-for-ufc-losses-i-lost-because-i-wasnt-good-enough">Ben Askren not using hip injury as excuse for UFC losses: &#8216;I lost because I wasn&#8217;t good enough&#8217;</a>
							<span>&#40;November 20&#41;</span>
						</div>
											<div class="marquee-list">
							<a href="https://www.mmaweekly.com/ufc-hall-of-fame-historic-fight-shogun-rua-vs-dan-henderson">UFC Hall of Fame historic fight: Shogun Rua vs. Dan Henderson</a>
							<span>&#40;November 20&#41;</span>
						</div>
									</div>
			</div>
			
		</div>
	</div>
 
						</div>
					</div>
				</div>
			</div>
					</div>
		<div class="container">	<div class="carousel-wrap clearfix">
			<div class="latest-carousel block4">	
				<div class="owl_carousel" data-grid="4" data-speed="1000">	
										<div class="post-428689 latest-carousel-item">
						<div class="mediaholder">
							<a href="https://www.mmaweekly.com/ben-askren-calls-it-a-career-announces-his-retirement"><img width="440" height="310" src="https://cdn.mmaweekly.com/wp-content/uploads/2019/06/ben-askren-ufc239mediaday-750-440x310.jpg" class="attachment-block4-three size-block4-three wp-post-image" alt="Ben Askren at UFC 239 media day" srcset="https://cdn.mmaweekly.com/wp-content/uploads/2019/06/ben-askren-ufc239mediaday-750-440x310.jpg 440w, https://cdn.mmaweekly.com/wp-content/uploads/2019/06/ben-askren-ufc239mediaday-750-100x70.jpg 100w" sizes="(max-width: 440px) 100vw, 440px" /></a><h2>featured<a href="https://www.mmaweekly.com/ben-askren-calls-it-a-career-announces-his-retirement">Ben Askren calls it a career, announces his retirement</a></h2>						</div>
					</div>
					
					
										<div class="post-428637 latest-carousel-item">
						<div class="mediaholder">
							<a href="https://www.mmaweekly.com/shogun-rua-frustrated-with-ufc-on-espn-22-judges-wants-rematch-with-paul-craig"><img width="440" height="310" src="https://cdn.mmaweekly.com/wp-content/uploads/2019/11/shogun-rua-ufcEspn22-post-750-440x310.jpg" class="attachment-block4-three size-block4-three wp-post-image" alt="" srcset="https://cdn.mmaweekly.com/wp-content/uploads/2019/11/shogun-rua-ufcEspn22-post-750-440x310.jpg 440w, https://cdn.mmaweekly.com/wp-content/uploads/2019/11/shogun-rua-ufcEspn22-post-750-100x70.jpg 100w" sizes="(max-width: 440px) 100vw, 440px" /></a><h2>featured<a href="https://www.mmaweekly.com/shogun-rua-frustrated-with-ufc-on-espn-22-judges-wants-rematch-with-paul-craig">Shogun Rua frustrated with UFC on ESPN+ 22 judges, wants rematch with Paul Craig</a></h2>						</div>
					</div>
					
					
										<div class="post-428615 latest-carousel-item">
						<div class="mediaholder">
							<a href="https://www.mmaweekly.com/jan-blachowicz-squeaks-past-jacare-souza-in-ufc-on-espn-22-main-event"><img width="440" height="310" src="https://cdn.mmaweekly.com/wp-content/uploads/2019/11/jan-blachowicz-UFCESPN22-750-440x310.jpg" class="attachment-block4-three size-block4-three wp-post-image" alt="" srcset="https://cdn.mmaweekly.com/wp-content/uploads/2019/11/jan-blachowicz-UFCESPN22-750-440x310.jpg 440w, https://cdn.mmaweekly.com/wp-content/uploads/2019/11/jan-blachowicz-UFCESPN22-750-100x70.jpg 100w" sizes="(max-width: 440px) 100vw, 440px" /></a><h2>featured<a href="https://www.mmaweekly.com/jan-blachowicz-squeaks-past-jacare-souza-in-ufc-on-espn-22-main-event">Jan Błachowicz squeaks past &#8216;Jacare&#8217; Souza in UFC on ESPN+ 22 main event</a></h2>						</div>
					</div>
					
					
										<div class="post-428291 latest-carousel-item">
						<div class="mediaholder">
							<a href="https://www.mmaweekly.com/ufc-on-espn-plus-22-live-results-blachowicz-vs-jacare-sao-paulo-brazil"><img width="440" height="310" src="https://cdn.mmaweekly.com/wp-content/uploads/2019/11/UFC-Sao-Paulo-Blachowicz-vs-Jacare-live-results-440x310.jpg" class="attachment-block4-three size-block4-three wp-post-image" alt="UFC Sao Paulo Blachowicz vs Jacare live results" srcset="https://cdn.mmaweekly.com/wp-content/uploads/2019/11/UFC-Sao-Paulo-Blachowicz-vs-Jacare-live-results-440x310.jpg 440w, https://cdn.mmaweekly.com/wp-content/uploads/2019/11/UFC-Sao-Paulo-Blachowicz-vs-Jacare-live-results-100x70.jpg 100w" sizes="(max-width: 440px) 100vw, 440px" /></a><h2>featured<a href="https://www.mmaweekly.com/ufc-on-espn-plus-22-live-results-blachowicz-vs-jacare-sao-paulo-brazil">UFC on ESPN+ 22 Live Results: Błachowicz vs. Jacaré (Results &#038; Fight Stats)</a></h2>						</div>
					</div>
					
					
									</div>
			</div>
	</div>
 <div class="row-fluid">														<div id="post-428799" class="span8 single-page post-428799 post type-post status-publish format-standard has-post-thumbnail hentry category-frontpage category-news tag-brandon-royval tag-legacy-fighting-alliance tag-lfa-79 tag-mma-news tag-nate-williams" >														<div class="block-title clearfix">																				<h2>Brandon Royval expects to &#8216;walk through&#8217; LFA flyweights en route to UFC</h2>																	<!--<div class="single-navs">							<div class="single-nav nav-prev">								<a href="https://www.mmaweekly.com/ufc-hall-of-fame-historic-fight-shogun-rua-vs-dan-henderson" rel="prev"><i class="icon-angle-left"></i></a>							</div>							<div class="single-nav nav-next">								<a href="https://www.mmaweekly.com/ben-askren-not-using-hip-injury-as-excuse-for-ufc-losses-i-lost-because-i-wasnt-good-enough" rel="next"><i class="icon-angle-right"></i></a>							</div>						</div> 	-->										</div>																																


						<div class="single-meta clearfix">					<div class="date"><i class="icon-calendar"></i>November 20, 2019</div>					<div class="comments spot-im-replies-count" data-min-count="1" data-placeholder-class="mma-num-replies" data-post-id="428799"><i class="icon-comments"></i><a href="https://www.mmaweekly.com/brandon-royval-expects-to-walk-through-lfa-flyweights-en-route-to-ufc#comments"><span class="no-comments">No</span><span class="mma-num-replies">No</span>&nbsp;Comments</a></div>						<div class="author"><i class="icon-user"></i><a href="https://www.mmaweekly.com/author/mick-hammond" title="Posts by Mick Hammond" rel="author">Mick Hammond</a></div>			<div class="category"><ul class="about-social clearfix" style="margin-top:0px !important;"><li><span class="fb-share-button" data-width="90" data-type="button_count"></span></li><li><span><a href="https://twitter.com/share" class="twitter-share-button" data-count="horizontal" data-text="Share" data-url="https://www.mmaweekly.com/brandon-royval-expects-to-walk-through-lfa-flyweights-en-route-to-ufc" ></a></span></li></ul> 
</div>				</div>				

<div class="single-media clearfix"><div class="single-image mediaholder">

 <img width="100%" src="https://cdn.mmaweekly.com/wp-content/uploads/2019/11/Brandon-Royval-750.jpg" title="Brandon Royval expects to &#8216;walk through&#8217; LFA flyweights en route to UFC" />
</div></div>
  
<!-- Begin Sortable BTF_Leaderboard_Respoonsive (responsive 728x90, 300x250) -->
	<div class="ad-tag" data-ad-name="BTF_Leaderboard_Respoonsive" data-ad-size="auto" ></div>
<script src="//tags-cdn.deployads.com/a/mmaweekly.com.js" async ></script>
<script>(deployads = window.deployads || []).push({});</script>
	<p> </p>
<!-- End Sortable BTF_Leaderboard_Respoonsive -->

	<div class="single-content clearfix">				<p>When it comes to his first-round submission victory over Joby Sanchez at LFA 65 in May, flyweight Brandon Royval has very little to be disappointed with. He believes he&#8217;ll keep rolling over LFA flyweights en route to his arrival in the UFC Octagon.</p>
<p>Looking back on the Sanchez fight, Royval feels he did just about everything he could have wanted to do in the fight in terms of showcasing his skillset.</p>
<p>“I thought it was a good performance for me,” Royval told MMAWeekly.com. “I thought it was a good showing.</p>
<p>“I thought I was good with my stand-up. I thought I was good on the ground. I had a few takedowns. Other than that I would have liked a quicker finish.”</p>
<p>Following the win over Sanchez, Royval was supposed to face Jarome Rivera in October for the LFA flyweight title, but due to the promotion’s problems with AXS TV with their television deal, the event was scrapped.</p>
<p>“Honestly I was pretty heartbroken (not being able to face Rivera),” said Royval. “I had a pretty good camp. I was right on weight. Everything went smooth. The match-up was perfect for me.</p>
<p>“A week and a half out we got the news (of the cancellation). I stayed the course. I didn’t skip any practices after that. I was just frustrated kind of waiting to see where it was going to go.”</p>
<p>On Friday in Broomfield, Colo., Royval (9-4) will get his long-awaited title shot when he faces late replacement Nate Williams (29-18) in the 125-pound championship main event of LFA 79.</p>
<p><strong>TRENDING &gt;&nbsp;</strong><strong><a title="Yoel Romero angling for Israel Adesanya title fight with Paulo Costa sidelined" href="https://www.mmaweekly.com/yoel-romero-angling-for-israel-adesanya-title-fight-with-paulo-costa-sidelined">Yoel Romero angling for Israel Adesanya title fight with Paulo Costa sidelined</a></strong></p>
<p>“All I think have to do is go out there and be myself,” Royval said. “I don’t do anything special against any of the opponents I’m matched up against. This is my fourth opponent change as far as this camp goes. I’m just staying focused on me and getting better myself.</p>
<p>“Sometimes we do a little bit of game planning, but for this fight I think going out there and being myself is enough. I have (Williams) beat everywhere. I don’t know where he beats me; standing up or on the ground; I think I’m perfect there.”</p>
<p>With an LFA title usually being a precursor to fighters moving up to the next level, Royval could very well find himself making that step up in 2020, but until it actually happens he’s going to focus directly on what is in front of him.</p>
<p>“I know the opportunities that this fight comes with,” said Royval. “I see that being a possibility that the UFC will be the next option, and I’m hoping that will be the next thing too, but I want to take it one fight at a time.</p>
<p>“For this fight it’s more about making a statement; not only that I’m the best one that’s not in the UFC, but I’m by far the best and that I’m going to walk through all these flyweights that are in my path.”</p>
<div style="min-height:33px;" class="really_simple_share really_simple_share_button robots-nocontent snap_nopreview"><div class="really_simple_share_twitter" style="width:100px;"><a href="https://twitter.com/share" class="twitter-share-button" data-count="horizontal"  data-text="Brandon Royval expects to &#8216;walk through&#8217; LFA flyweights en route to UFC" data-url="https://www.mmaweekly.com/brandon-royval-expects-to-walk-through-lfa-flyweights-en-route-to-ufc"  data-via=""   ></a></div><div class="really_simple_share_facebook_share_new" style="width:100px;"><div class="fb-share-button" data-href="https://www.mmaweekly.com/brandon-royval-expects-to-walk-through-lfa-flyweights-en-route-to-ufc" data-type="button_count" data-width="100"></div></div></div>
		<div class="really_simple_share_clearfix"></div> 									</div>					
	
<!-- BEGIN Sortable 728x90-300x250 Lower -->
	<div class="ad-tag" data-ad-name="BTF_Leaderboard Responsive 728x90_300x250" data-ad-size="auto" ></div>
	<script src="//tags-cdn.deployads.com/a/mmaweekly.com.js" async ></script>
	<script>(deployads = window.deployads || []).push({});</script>
	<p></p>
<!-- END Sortable 728x90-300x250 Lower -->
	
<!-- Begin Taboola below article thumbnails -->  
<div id="taboola-below-article-thumbnails"></div>
<script type="text/javascript">
  window._taboola = window._taboola || [];
  _taboola.push({
    mode: 'thumbnails-a',
    container: 'taboola-below-article-thumbnails',
    placement: 'Below Article Thumbnails',
    target_type: 'mix'
  });
</script>
<!-- End Taboola below article thumbnails -->  
	
<!-- BEGIN Spot.IM Popular in Community & Comments -->
			<a name="comments"></a>			<div class="single-comments clearfix">				
<div data-spotim-module="recirculation" data-spot-id="sp_3qtDoO8S"></div>
<script src="https://recirculation.spot.im/spot/sp_3qtDoO8S"></script>
<script async src="https://launcher.spot.im/spot/sp_3qtDoO8S"
    data-spotim-module="spotim-launcher"
    data-post-id="428799"
    data-post-url="https://www.mmaweekly.com/brandon-royval-expects-to-walk-through-lfa-flyweights-en-route-to-ufc"
    data-article-tags="Brandon Royval, Legacy Fighting Alliance, LFA 79, MMA News, Nate Williams, frontpage, news"
	data-disqus-url="https://www.mmaweekly.com/brandon-royval-expects-to-walk-through-lfa-flyweights-en-route-to-ufc"
    data-disqus-identifier="428799 https://www.mmaweekly.com/brandon-royval-expects-to-walk-through-lfa-flyweights-en-route-to-ufc"></script>
<!-- END Spot.IM Popular in Community & Comments -->
	
																					

	
	</div>		</div>
	
	
				<div class="sidebar span4">				<div id="custom_html-8" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><div class="ad-tag" data-ad-name="ATF_Halfpage_Responsive" data-ad-size="auto" ></div>
<script src="//tags-cdn.deployads.com/a/mmaweekly.com.js" async ></script>
<script>(deployads = window.deployads || []).push({});</script></div></div><div id="custom_html-3" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><script src="https://apis.google.com/js/platform.js"></script>
<center><div class="g-ytsubscribe" data-channelid="UC7tdFNggH_jwjJTDWqYelmA" data-layout="full" data-theme="dark" data-count="default"></div><p></p>
</center></div></div><div id="custom_html-23" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><center><a href="https://www.facebook.com/MMAWeeklyOfficial/" target="_blank" rel="noopener noreferrer"><img src="https://cdn.mmaweekly.com/wp-content/uploads/2014/08/facebook.png" alt="facebook" width="32px" height="32px" /></a>&emsp; &emsp; <a href="https://twitter.com/mmaweeklycom" target="_blank" rel="noopener noreferrer"><img src="https://cdn.mmaweekly.com/wp-content/uploads/2014/08/twitter.png" alt="twitter" width="32px" height="32px" /></a>&emsp; &emsp; <a href="https://instagram.com/mmaweekly" target="_blank" rel="noopener noreferrer"><img src="https://cdn.mmaweekly.com/wp-content/uploads/2014/08/instagram.png" alt="instagram" width="32px" height="32px" /></a>&emsp; &emsp; <a href="/feed"><img src="https://cdn.mmaweekly.com/wp-content/uploads/2014/08/rss.png" alt="rss" width="32px" height="32px" /></a><p></p></center></div></div><div id="posts-widget-2" class="widget posts-widget"><h2 class="widgettitle">Hot Topics</h2><div class="widget-block">			
			<div class="small-post first clearfix">
				<div class="mediaholder small"><div class="caption-link"><a href="https://cdn.mmaweekly.com/wp-content/uploads/2019/10/Demian-Maia-chokes-out-Ben-Askren-at-UFC-Singapore.jpg" title="" class="show-image caption-type first"><i class="icon-search"></i></a><a href="https://www.mmaweekly.com/ben-askren-not-using-hip-injury-as-excuse-for-ufc-losses-i-lost-because-i-wasnt-good-enough" title="Ben Askren not using hip injury as excuse for UFC losses: &#8216;I lost because I wasn&#8217;t good enough&#8217;"><i class="icon-plus"></i></a></div><a href="https://www.mmaweekly.com/ben-askren-not-using-hip-injury-as-excuse-for-ufc-losses-i-lost-because-i-wasnt-good-enough" title=""><img width="100" height="70" src="https://cdn.mmaweekly.com/wp-content/uploads/2019/10/Demian-Maia-chokes-out-Ben-Askren-at-UFC-Singapore-100x70.jpg" class="attachment-mediaholder-small size-mediaholder-small wp-post-image" alt="Demian Maia chokes out Ben Askren at UFC Singapore" srcset="https://cdn.mmaweekly.com/wp-content/uploads/2019/10/Demian-Maia-chokes-out-Ben-Askren-at-UFC-Singapore-100x70.jpg 100w, https://cdn.mmaweekly.com/wp-content/uploads/2019/10/Demian-Maia-chokes-out-Ben-Askren-at-UFC-Singapore-440x310.jpg 440w" sizes="(max-width: 100px) 100vw, 100px" /></a></div><div class="detailholder small"><h3><a href="https://www.mmaweekly.com/ben-askren-not-using-hip-injury-as-excuse-for-ufc-losses-i-lost-because-i-wasnt-good-enough" title="Ben Askren not using hip injury as excuse for UFC losses: &#8216;I lost because I wasn&#8217;t good enough&#8217;">Ben Askren not using hip injury as excuse for UFC losses: &#8216;I lost because I wasn&#82...</a></h3><div class="detailmeta"><p></p></div></div>			</div>
		
					
			<div class="small-post clearfix">
				<div class="mediaholder small"><div class="caption-link"><a href="https://cdn.mmaweekly.com/wp-content/uploads/2019/11/Dana-White-over-Zhang-and-Jedrzejczyk.jpg" title="" class="show-image caption-type first"><i class="icon-search"></i></a><a href="https://www.mmaweekly.com/dana-white-hints-at-weili-zhang-vs-joanna-jedrzejczyk-coming-soon" title="Dana White hints at Weili Zhang vs. Joanna Jedrzejczyk coming soon"><i class="icon-plus"></i></a></div><a href="https://www.mmaweekly.com/dana-white-hints-at-weili-zhang-vs-joanna-jedrzejczyk-coming-soon" title=""><img width="100" height="70" src="https://cdn.mmaweekly.com/wp-content/uploads/2019/11/Dana-White-over-Zhang-and-Jedrzejczyk-100x70.jpg" class="attachment-mediaholder-small size-mediaholder-small wp-post-image" alt="Dana White over Zhang and Jedrzejczyk" srcset="https://cdn.mmaweekly.com/wp-content/uploads/2019/11/Dana-White-over-Zhang-and-Jedrzejczyk-100x70.jpg 100w, https://cdn.mmaweekly.com/wp-content/uploads/2019/11/Dana-White-over-Zhang-and-Jedrzejczyk-440x310.jpg 440w" sizes="(max-width: 100px) 100vw, 100px" /></a></div><div class="detailholder small"><h3><a href="https://www.mmaweekly.com/dana-white-hints-at-weili-zhang-vs-joanna-jedrzejczyk-coming-soon" title="Dana White hints at Weili Zhang vs. Joanna Jedrzejczyk coming soon">Dana White hints at Weili Zhang vs. Joanna Jedrzejczyk coming soon</a></h3><div class="detailmeta"><p></p></div></div>			</div>
		
					
			<div class="small-post clearfix">
				<div class="mediaholder small"><div class="caption-link"><a href="https://cdn.mmaweekly.com/wp-content/uploads/2019/08/Yoel-Romero-UFC-241-media-day.jpg" title="" class="show-image caption-type first"><i class="icon-search"></i></a><a href="https://www.mmaweekly.com/yoel-romero-angling-for-israel-adesanya-title-fight-with-paulo-costa-sidelined" title="Yoel Romero angling for Israel Adesanya title fight with Paulo Costa sidelined"><i class="icon-plus"></i></a></div><a href="https://www.mmaweekly.com/yoel-romero-angling-for-israel-adesanya-title-fight-with-paulo-costa-sidelined" title=""><img width="100" height="70" src="https://cdn.mmaweekly.com/wp-content/uploads/2019/08/Yoel-Romero-UFC-241-media-day-100x70.jpg" class="attachment-mediaholder-small size-mediaholder-small wp-post-image" alt="Yoel Romero UFC 241 media day" srcset="https://cdn.mmaweekly.com/wp-content/uploads/2019/08/Yoel-Romero-UFC-241-media-day-100x70.jpg 100w, https://cdn.mmaweekly.com/wp-content/uploads/2019/08/Yoel-Romero-UFC-241-media-day-440x310.jpg 440w" sizes="(max-width: 100px) 100vw, 100px" /></a></div><div class="detailholder small"><h3><a href="https://www.mmaweekly.com/yoel-romero-angling-for-israel-adesanya-title-fight-with-paulo-costa-sidelined" title="Yoel Romero angling for Israel Adesanya title fight with Paulo Costa sidelined">Yoel Romero angling for Israel Adesanya title fight with Paulo Costa sidelined</a></h3><div class="detailmeta"><p></p></div></div>			</div>
		
					
			<div class="small-post clearfix">
				<div class="mediaholder small"><div class="caption-link"><a href="https://cdn.mmaweekly.com/wp-content/uploads/2019/06/ben-askren-ufc239mediaday-750.jpg" title="" class="show-image caption-type first"><i class="icon-search"></i></a><a href="https://www.mmaweekly.com/ben-askren-calls-it-a-career-announces-his-retirement" title="Ben Askren calls it a career, announces his retirement"><i class="icon-plus"></i></a></div><a href="https://www.mmaweekly.com/ben-askren-calls-it-a-career-announces-his-retirement" title=""><img width="100" height="70" src="https://cdn.mmaweekly.com/wp-content/uploads/2019/06/ben-askren-ufc239mediaday-750-100x70.jpg" class="attachment-mediaholder-small size-mediaholder-small wp-post-image" alt="Ben Askren at UFC 239 media day" srcset="https://cdn.mmaweekly.com/wp-content/uploads/2019/06/ben-askren-ufc239mediaday-750-100x70.jpg 100w, https://cdn.mmaweekly.com/wp-content/uploads/2019/06/ben-askren-ufc239mediaday-750-440x310.jpg 440w" sizes="(max-width: 100px) 100vw, 100px" /></a></div><div class="detailholder small"><h3><a href="https://www.mmaweekly.com/ben-askren-calls-it-a-career-announces-his-retirement" title="Ben Askren calls it a career, announces his retirement">Ben Askren calls it a career, announces his retirement</a></h3><div class="detailmeta"><p></p></div></div>			</div>
		
					
			<div class="small-post last clearfix">
				<div class="mediaholder small"><div class="caption-link"><a href="https://cdn.mmaweekly.com/wp-content/uploads/2019/05/Anthony-Johnson-UFC-210-prefight-scrum.jpg" title="" class="show-image caption-type first"><i class="icon-search"></i></a><a href="https://www.mmaweekly.com/anthony-rumble-johnson-training-for-ufc-return-at-heavyweight" title="Anthony &#8216;Rumble&#8217; Johnson training for UFC return at heavyweight"><i class="icon-plus"></i></a></div><a href="https://www.mmaweekly.com/anthony-rumble-johnson-training-for-ufc-return-at-heavyweight" title=""><img width="100" height="70" src="https://cdn.mmaweekly.com/wp-content/uploads/2019/05/Anthony-Johnson-UFC-210-prefight-scrum-100x70.jpg" class="attachment-mediaholder-small size-mediaholder-small wp-post-image" alt="Anthony Johnson UFC 210 prefight scrum" srcset="https://cdn.mmaweekly.com/wp-content/uploads/2019/05/Anthony-Johnson-UFC-210-prefight-scrum-100x70.jpg 100w, https://cdn.mmaweekly.com/wp-content/uploads/2019/05/Anthony-Johnson-UFC-210-prefight-scrum-440x310.jpg 440w" sizes="(max-width: 100px) 100vw, 100px" /></a></div><div class="detailholder small"><h3><a href="https://www.mmaweekly.com/anthony-rumble-johnson-training-for-ufc-return-at-heavyweight" title="Anthony &#8216;Rumble&#8217; Johnson training for UFC return at heavyweight">Anthony &#8216;Rumble&#8217; Johnson training for UFC return at heavyweight</a></h3><div class="detailmeta"><p></p></div></div>			</div>
		
		</div></div><div id="custom_html-18" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><div class="ad-tag" data-ad-name="BTF_Rectangle_300x250_Sticky" data-ad-size="300x250" ></div>
<script src="//tags-cdn.deployads.com/a/mmaweekly.com.js" async ></script>
<script>(deployads = window.deployads || []).push({});</script></div></div><div id="posts-widget-6" class="widget posts-widget"><h2 class="widgettitle">Hot Sauce</h2><div class="widget-block">			
			<div class="small-post first clearfix">
				<div class="mediaholder small"><div class="caption-link"><a href="https://cdn.mmaweekly.com/wp-content/uploads/2019/11/Rolling-thunder-kick-Ross-Pearson-KO.jpg" title="" class="show-image caption-type first"><i class="icon-search"></i></a><a href="https://www.mmaweekly.com/video-check-out-the-rolling-thunder-kick-that-laid-ross-pearson-out-cold" title="Video: Check out the rolling thunder kick that laid Ross Pearson out cold"><i class="icon-plus"></i></a></div><a href="https://www.mmaweekly.com/video-check-out-the-rolling-thunder-kick-that-laid-ross-pearson-out-cold" title=""><img width="100" height="70" src="https://cdn.mmaweekly.com/wp-content/uploads/2019/11/Rolling-thunder-kick-Ross-Pearson-KO-100x70.jpg" class="attachment-mediaholder-small size-mediaholder-small wp-post-image" alt="Rolling thunder kick - Ross Pearson KO" srcset="https://cdn.mmaweekly.com/wp-content/uploads/2019/11/Rolling-thunder-kick-Ross-Pearson-KO-100x70.jpg 100w, https://cdn.mmaweekly.com/wp-content/uploads/2019/11/Rolling-thunder-kick-Ross-Pearson-KO-440x310.jpg 440w" sizes="(max-width: 100px) 100vw, 100px" /></a></div><div class="detailholder small"><h3><a href="https://www.mmaweekly.com/video-check-out-the-rolling-thunder-kick-that-laid-ross-pearson-out-cold" title="Video: Check out the rolling thunder kick that laid Ross Pearson out cold">Video: Check out the rolling thunder kick that laid Ross Pearson out cold</a></h3><div class="detailmeta"><p></p></div></div>			</div>
		
					
			<div class="small-post clearfix">
				<div class="mediaholder small"><div class="caption-link"><a href="https://cdn.mmaweekly.com/wp-content/uploads/2019/04/Amanda-Nunes-UFC-236-seasonal-presser-two-belts.jpg" title="" class="show-image caption-type first"><i class="icon-search"></i></a><a href="https://www.mmaweekly.com/boxer-claressa-shieldss-promoter-believes-amanda-nunes-fight-could-happen-next-year" title="Boxer Claressa Shields&#8217;s promoter believes Amanda Nunes fight could happen next year"><i class="icon-plus"></i></a></div><a href="https://www.mmaweekly.com/boxer-claressa-shieldss-promoter-believes-amanda-nunes-fight-could-happen-next-year" title=""><img width="100" height="70" src="https://cdn.mmaweekly.com/wp-content/uploads/2019/04/Amanda-Nunes-UFC-236-seasonal-presser-two-belts-100x70.jpg" class="attachment-mediaholder-small size-mediaholder-small wp-post-image" alt="Amanda Nunes UFC 236 seasonal presser two belts" srcset="https://cdn.mmaweekly.com/wp-content/uploads/2019/04/Amanda-Nunes-UFC-236-seasonal-presser-two-belts-100x70.jpg 100w, https://cdn.mmaweekly.com/wp-content/uploads/2019/04/Amanda-Nunes-UFC-236-seasonal-presser-two-belts-440x310.jpg 440w" sizes="(max-width: 100px) 100vw, 100px" /></a></div><div class="detailholder small"><h3><a href="https://www.mmaweekly.com/boxer-claressa-shieldss-promoter-believes-amanda-nunes-fight-could-happen-next-year" title="Boxer Claressa Shields&#8217;s promoter believes Amanda Nunes fight could happen next year">Boxer Claressa Shields&#8217;s promoter believes Amanda Nunes fight could happen next year</a></h3><div class="detailmeta"><p></p></div></div>			</div>
		
					
			<div class="small-post clearfix">
				<div class="mediaholder small"><div class="caption-link"><a href="https://cdn.mmaweekly.com/wp-content/uploads/2019/11/Jorge-Masvidal-UFC-244-Post-750x370-Conor-Mcgregor.jpg" title="" class="show-image caption-type first"><i class="icon-search"></i></a><a href="https://www.mmaweekly.com/jorge-masvidal-ill-mess-that-midget-conor-mcgregor-up" title="Jorge Masvidal: I&#8217;ll  mess that &#8220;midget&#8221; Conor McGregor up"><i class="icon-plus"></i></a></div><a href="https://www.mmaweekly.com/jorge-masvidal-ill-mess-that-midget-conor-mcgregor-up" title=""><img width="100" height="70" src="https://cdn.mmaweekly.com/wp-content/uploads/2019/11/Jorge-Masvidal-UFC-244-Post-750x370-Conor-Mcgregor-100x70.jpg" class="attachment-mediaholder-small size-mediaholder-small wp-post-image" alt="Conor McGregor and Jorge Masvidal" srcset="https://cdn.mmaweekly.com/wp-content/uploads/2019/11/Jorge-Masvidal-UFC-244-Post-750x370-Conor-Mcgregor-100x70.jpg 100w, https://cdn.mmaweekly.com/wp-content/uploads/2019/11/Jorge-Masvidal-UFC-244-Post-750x370-Conor-Mcgregor-440x310.jpg 440w" sizes="(max-width: 100px) 100vw, 100px" /></a></div><div class="detailholder small"><h3><a href="https://www.mmaweekly.com/jorge-masvidal-ill-mess-that-midget-conor-mcgregor-up" title="Jorge Masvidal: I&#8217;ll  mess that &#8220;midget&#8221; Conor McGregor up">Jorge Masvidal: I&#8217;ll  mess that &#8220;midget&#8221; Conor McGregor up</a></h3><div class="detailmeta"><p></p></div></div>			</div>
		
					
			<div class="small-post clearfix">
				<div class="mediaholder small"><div class="caption-link"><a href="https://cdn.mmaweekly.com/wp-content/uploads/2019/11/Jorge-Masvidal-Nate-Diaz-Dwayne-Rock-Johnson.jpg" title="" class="show-image caption-type first"><i class="icon-search"></i></a><a href="https://www.mmaweekly.com/fighters-are-angry-about-the-ufc-244-main-event-doctor-stoppage" title="Fighters are angry about the UFC 244 main event doctor stoppage"><i class="icon-plus"></i></a></div><a href="https://www.mmaweekly.com/fighters-are-angry-about-the-ufc-244-main-event-doctor-stoppage" title=""><img width="100" height="70" src="https://cdn.mmaweekly.com/wp-content/uploads/2019/11/Jorge-Masvidal-Nate-Diaz-Dwayne-Rock-Johnson-100x70.jpg" class="attachment-mediaholder-small size-mediaholder-small wp-post-image" alt="Jorge Masvidal - Nate Diaz- Dwayne Rock Johnson" srcset="https://cdn.mmaweekly.com/wp-content/uploads/2019/11/Jorge-Masvidal-Nate-Diaz-Dwayne-Rock-Johnson-100x70.jpg 100w, https://cdn.mmaweekly.com/wp-content/uploads/2019/11/Jorge-Masvidal-Nate-Diaz-Dwayne-Rock-Johnson-440x310.jpg 440w" sizes="(max-width: 100px) 100vw, 100px" /></a></div><div class="detailholder small"><h3><a href="https://www.mmaweekly.com/fighters-are-angry-about-the-ufc-244-main-event-doctor-stoppage" title="Fighters are angry about the UFC 244 main event doctor stoppage">Fighters are angry about the UFC 244 main event doctor stoppage</a></h3><div class="detailmeta"><p></p></div></div>			</div>
		
					
			<div class="small-post last clearfix">
				<div class="mediaholder small"><div class="caption-link"><a href="https://cdn.mmaweekly.com/wp-content/uploads/2018/06/Colby-Covington-UFC-225-Media-Day.jpg" title="" class="show-image caption-type first"><i class="icon-search"></i></a><a href="https://www.mmaweekly.com/colby-covington-on-ufc-244-bmf-title-fight-softest-expletive-fight-on-the-planet" title="Colby Covington on UFC 244 BMF title fight: &#8216;softest (expletive) fight on the planet&#8217;"><i class="icon-plus"></i></a></div><a href="https://www.mmaweekly.com/colby-covington-on-ufc-244-bmf-title-fight-softest-expletive-fight-on-the-planet" title=""><img width="100" height="70" src="https://cdn.mmaweekly.com/wp-content/uploads/2018/06/Colby-Covington-UFC-225-Media-Day-100x70.jpg" class="attachment-mediaholder-small size-mediaholder-small wp-post-image" alt="Colby Covington UFC 225 Media Day" srcset="https://cdn.mmaweekly.com/wp-content/uploads/2018/06/Colby-Covington-UFC-225-Media-Day-100x70.jpg 100w, https://cdn.mmaweekly.com/wp-content/uploads/2018/06/Colby-Covington-UFC-225-Media-Day-440x310.jpg 440w" sizes="(max-width: 100px) 100vw, 100px" /></a></div><div class="detailholder small"><h3><a href="https://www.mmaweekly.com/colby-covington-on-ufc-244-bmf-title-fight-softest-expletive-fight-on-the-planet" title="Colby Covington on UFC 244 BMF title fight: &#8216;softest (expletive) fight on the planet&#8217;">Colby Covington on UFC 244 BMF title fight: &#8216;softest (expletive) fight on the planet...</a></h3><div class="detailmeta"><p></p></div></div>			</div>
		
		</div></div><div id="custom_html-11" class="widget_text widget widget_custom_html"><h2 class="widgettitle">MMA Ring Girl Gallery</h2><div class="textwidget custom-html-widget"><center>
	<p style="text-align: center;"><em><strong><a style="color: #ff0000;" title="MMA Ring Girl Galleries" href="https://www.mmaweekly.com/media/ring-girl-gallery">Click an image below for Ring Girl Gallery</a></strong></em></p>
<a title="MMA Ring Girl Galleries" href="https://www.mmaweekly.com/media/ring-girl-gallery"><img class="aligncenter wp-image-285192" src="https://cdn.mmaweekly.com/wp-content/uploads/2018/01/2018-New-Ring-Girl-Graphic.jpg" alt="MMA Ring Girls" width="250" height="374" /></a>
</center></div></div>			</div>			</div> </div>
	
	<div class="footer-wrap clearfix">
		<div class="container">
			<div class="row-fluid">
				<div class="span12">
					<div class="footer-widget clearfix">
						<div class="row-fluid">
																	<!-- Widget 1 -->
		<div class="span4 first">
			<div id="custom_html-15" class="widget_text footer_widget widget_custom_html"><div class="textwidget custom-html-widget"><strong>MMAWEEKLY SOCIAL</strong><br />
<a href="https://www.facebook.com/MMAWeeklyOfficial">Follow MMAWeekly on Facebook</a><br />
<a href="https://twitter.com/#!/mmaweeklycom">Follow MMAWeekly on Twitter</a><br />
<a href="https://www.youtube.com/subscription_center?add_user=mmaweeklyvideos">Follow MMAWeekly on YouTube</a><br />
<hr />
<strong>PAGES</strong><br />
<a href="https://www.mmaweekly.com/">MMAWeekly.com Home</a><br />
<a href="https://www.mmaweekly.com/category/ufcnews">UFC News</a><br />
<a href="https://www.mmaweekly.com/news">MMA News</a><br />
<a href="https://www.mmaweekly.com/hot-sauce">MMA Hot Sauce Blog</a><br />
<a href="https://www.mmaweekly.com/rumors">MMA Rumors</a><br />
<a href="https://www.mmaweekly.com/category/video">MMA Videos</a><br />
<a href="https://www.mmaweekly.com/category/photos">MMA Photos</a><br />
<a href="https://www.mmaweekly.com/category/podcast-2">MMA Podcasts</a><br />
<a href="https://www.mmaweekly.com/contact-us">Contact Us</a><br />
<a href="https://www.mmaweekly.com/privacy">Privacy Policy</a><br /> </div></div>		</div>
			
		<!-- Widget 2 -->
		<div class="span4">
			<div id="custom_html-16" class="widget_text footer_widget widget_custom_html"><div class="textwidget custom-html-widget"><strong>UPCOMING EVENTS</strong><br />
<a title="UFC 235: Jones vs Smith Fight Card Rumors" href="/ufc-235-fight-card">UFC 235: Jones vs Smith</a><br /></div></div>		</div>
			
		<!-- Widget 3 -->
		<div class="span4 last">
			<div id="custom_html-17" class="widget_text footer_widget widget_custom_html"><div class="textwidget custom-html-widget"><strong>MORE SITES / BLOGS</strong><br />
<a href="http://sports.yahoo.com/ufc" target="_blank" rel="noopener noreferrer">Yahoo! Sports</a><br />
<a href="http://bleacherreport.com/ufc" target="_blank" rel="noopener noreferrer">Bleacher Report</a><br />
<a href="http://www.nerdcoremovement.com" target="_blank" rel="noopener noreferrer">Nerdcore Movement</a><br />
<a href="https://asianmma.com" target="_blank" rel="noopener noreferrer">Asian MMA</a><br /><a href="http://knockoutradio.com/" target="_blank" rel="noopener noreferrer">Knockout Radio</a><br />
<a href="http://agfight.band.uol.com.br/en/" target="_blank" rel="noopener noreferrer">AgFight</a><br />
<a href="http://www.fightline.com" target="_blank" rel="noopener noreferrer">Fightline</a><br />
<a href="http://mmalinker.com/newsfeed" target="_blank" rel="noopener noreferrer">MMA Linker</a><br />
<a href="http://www.addictedtomma.com/" target="_blank" rel="noopener noreferrer">Addicted to MMA</a><br /></div></div>		</div>													</div>
					</div>

											<div class="footer clearfix">
																					<div class="footer-right">
								<div class="bottom-menu">
									<ul id="bottomNav" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-255891"><a href="https://www.mmaweekly.com/">Home</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-363955"><a href="#">News</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-256172"><a href="https://www.mmaweekly.com/rumors">Events</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-398423"><a title="UFC-MMA Betting Odds" href="https://record.webpartners.co/_l67-Ms-ZybdpLtekF-chNmNd7ZgqdRLk/1/">UFC &#8211; MMA Odds</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-363957"><a href="#">Videos/Podcasts</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-255916"><a href="https://www.mmaweekly.com/hot-sauce">Hot Sauce</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-255922"><a href="https://www.mmaweekly.com/media/ring-girl-gallery">Ring Girls</a></li>
</ul>								</div>
							</div>
													</div>			
									</div>
			</div>
		</div>
	</div>
	<div id="back-top">
		<a href="#top"><span class="icon-long-arrow-up"></span></a>
	</div>
</div>

<!-- ngg_resource_manager_marker -->
  <div id="fb-root"></div>
  <script>(function(d, s, id) {
    var js, fjs = d.getElementsByTagName(s)[0];
    if (d.getElementById(id)) return;
    js = d.createElement(s); js.id = id;
    js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.0";
    fjs.parentNode.insertBefore(js, fjs);
  }(document, 'script', 'facebook-jssdk'));</script>	<script type="text/javascript">
		jQuery(window).ready(function() {
			// Sticky Header
							jQuery('.navigation').stickyMenu();
						
			// Navigation
			jQuery('.nav-wrap').flexMenu({
									breakpoint: 962,
								responsivePattern: 'toggle',
				animationSpeed: 300
			});
		});
		
					(function(d, s, id) {
				var js, fjs = d.getElementsByTagName(s)[0];
				if (d.getElementById(id)) return;
				js = d.createElement(s); js.id = id;
				js.src = "//connect.facebook.net/en_US/all.js#xfbml=1&appId=102226266616709";
				fjs.parentNode.insertBefore(js, fjs);
			}
			(document, 'script', 'facebook-jssdk'));
			
			(function() {
				window.PinIt = window.PinIt || { loaded:false };
				if (window.PinIt.loaded) return;
				window.PinIt.loaded = true;
				function async_load(){
					var s = document.createElement("script");
					s.type = "text/javascript";
					s.async = true;
					s.src = "https://assets.pinterest.com/js/pinit.js";
					var x = document.getElementsByTagName("script")[0];
					x.parentNode.insertBefore(s, x);
				}
				if (window.attachEvent)
					window.attachEvent("onload", async_load);
				else
					window.addEventListener("load", async_load, false);
			})();
				
		var retina = window.devicePixelRatio > 1 ? true : false;

        		
				
		
	</script>
<script type='text/javascript' src='https://cdn.mmaweekly.com/wp-includes/js/comment-reply.min.js'></script>
<script type='text/javascript' src='https://cdn.mmaweekly.com/wp-content/themes/orion/js/jquery.placeholder-enhanced.min.js'></script>
<script type='text/javascript' src='https://cdn.mmaweekly.com/wp-content/themes/orion/js/init.js'></script>
<script type='text/javascript' src='https://cdn.mmaweekly.com/wp-content/themes/orion/js/custom.js'></script>
<script type='text/javascript' src='https://platform.twitter.com/widgets.js'></script>
<script type='text/javascript' src='https://cdn.mmaweekly.com/wp-includes/js/wp-embed.min.js'></script>

</div>


<!-- siteContentSec -->

<!-- Spot.IM Message-Count Script -->
<script src="https://app-cdn.spot.im/modules/messages-count/3.0.126/bundle.js" type="text/javascript" async defer></script>

<!-- Taboola Body Script -->
<script type="text/javascript">
  window._taboola = window._taboola || [];
  _taboola.push({flush: true});
</script>

</body>


<!-- Facebook Share Function Script -->
<div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.5";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>


</html>

<style>
.about-social li {

margin-bottom: 0px !important;
}
</style>